IE bug displaying uploaded image files

I had some staff members discover a bug when using IE to upload jpegs. When using the Item Edit form to upload, the upload works correctly but the admin page does not display the thumbnail -- only a text link to the full image. Using FF, I get a thumbnail on the admin item record. More importantly, on the public item record it also does not render an img tag and display the image -- only a text link to fullsize.

I tested this out in both IE6 and IE7 (same result). Dreamhost is hosting us. Original and derivative files are present in Archive directory.

Based on examining some of our earliest test records, I realized this problem goes back to the .92 version (the first version I installed last July).

Strangely, Dropbox works correctly.

Really odd.


Have you updated the public themes to go w/ your current .10 installation?

There definitely seems to be a bug with the admin theme and I know that the dev team has been working on that theme.

I've been testing this out IE7 from my PC and am able to view an image on public side that I uploaded through IE. I get the same issue on admin but can see the full image here:

Can you see it?

OK, I do see your image.

I have updated my themes (though I've customized the display file function on the public record so that it displays fullsize (@350px) and links to archive file for largest size. I'm baffled with why this works correctly when uploading from FF -- I looked at the Files table in the DB and can't see any difference there.

I just switched the theme to .10 Thanks Roy and I still get only a text link on the public item record (where other records with files uploaded with FF display a thumbnail).

Update: Ok, also just tested the Omeka Sandbox in IE6 with same result (see "kkay test item" -- view from any browser and there is only a text link to file

There may something odd about how IE is reading the image data. We're not exactly sure, but were looking into it.