HTTP Error 500 (Internal Server Error) - Plugin Install

When I try to install a plugin on version 2.0.3 I always get a HTTP 500 error until I manually remove that plugin via FTP. The plugin I am trying to install is the Contribution plugin, however it happens with all plugins.

Contribution isn't updated for 2.0 yet, but I wouldn't have thought that would cause a 500. Maybe, though.

Does this happen with the plugins bundled in Omeka? If not, maybe it's that the other plugins aren't updated for 2.0 yet?

When I tried to install the commenting plugin (2.0) I also got the same error. It seems that only the plugins url of the site is giving me the 500 error, though.

I should also mention that we just upgraded from 1.x.x to 2.x.x

This is the actual error:

Notice: Use of undefined constant HELPERS - assumed 'HELPERS' in /home4/nolacity/public_html/nolacitymuseum/plugins/Tweetster/plugin.php on line 2

Warning: require_once(HELPERS) [function.require-once]: failed to open stream: No such file or directory in /home4/nolacity/public_html/nolacitymuseum/plugins/Tweetster/plugin.php on line 2

Fatal error: require_once() [function.require]: Failed opening required 'HELPERS' (include_path='/home4/nolacity/public_html/nolacitymuseum/application/libraries:/home4/nolacity/public_html/nolacitymuseum/application/models:.:/usr/share/pear:/usr/share/php:/home4/nolacity/public_html/nolacitymuseum/plugins/ExhibitBuilder/models:/home4/nolacity/public_html/nolacitymuseum/plugins/SimplePages/models:/home4/nolacity/public_html/nolacitymuseum/plugins/Geolocation/models') in /home4/nolacity/public_html/nolacitymuseum/plugins/Tweetster/plugin.php on line 2'

That was for tweester (which is not 2.0 comp).

Here is what I get with social bookmarking which is 2.0 comp:

Parse error: syntax error, unexpected T_CONST in /home4/nolacity/public_html/nolacitymuseum/plugins/SocialBookmarking/SocialBookmarkingPlugin.php on line 8

Anything not 2.0 comp, errors like that are to be expected.

The error with SocialBookmarking is more confusing. The first lines, up to the class SocialBookmarkingPlugin . . . . . . stuff should look like this:

 * Social Bookmarking
 * @copyright Copyright 2008-2013 Roy Rosenzweig Center for History and New Media
 * @license GNU GPLv3
const SOCIAL_BOOKMARKING_SERVICE_SETTINGS_OPTION = 'social_bookmarking_services';
const SOCIAL_BOOKMARKING_ADD_TO_OMEKA_ITEMS_OPTION = 'social_bookmarking_add_to_omeka_items';
const SOCIAL_BOOKMARKING_ADD_TO_OMEKA_COLLECTIONS_OPTION = 'social_bookmarking_add_to_omeka_collections';

require_once dirname(__FILE__) . '/helpers/SocialBookmarkingFunctions.php';

 * Social Bookmarking plugin.

If it doesn't, could you post here what it does look like, and try overwriting it with what's above?

never mind! investigation reveals it's a PHP version issue on our end.

So mine looks just like that. Any other ideas?

Seems like it's code that works with PHP 5.3 but not 5.2.

Try this as the first 20 lines, until just before the comment for the hooks

 * Social Bookmarking
 * @copyright Copyright 2008-2013 Roy Rosenzweig Center for History and New Media
 * @license GNU GPLv3

require_once dirname(__FILE__) . '/helpers/SocialBookmarkingFunctions.php';

 * Social Bookmarking plugin.
class SocialBookmarkingPlugin extends Omeka_Plugin_AbstractPlugin
    const ADDTHIS_SERVICES_URL = '';
    const SERVICE_SETTINGS_OPTION = 'social_bookmarking_services';
    const ADD_TO_OMEKA_ITEMS_OPTION = 'social_bookmarking_add_to_omeka_items';
    const ADD_TO_OMEKA_COLLECTIONS_OPTION = 'social_bookmarking_add_to_omeka_collections';

This is what I get:

#0 /home4/nolacity/public_html/nolacitymuseum/plugins/SocialBookmarking/helpers/SocialBookmarkingFunctions.php(47): SimpleXMLElement->__construct('')
#1 /home4/nolacity/public_html/nolacitymuseum/plugins/SocialBookmarking/helpers/SocialBookmarkingFunctions.php(57): social_bookmarking_get_services_xml()
#2 /home4/nolacity/public_html/nolacitymuseum/plugins/SocialBookmarking/helpers/SocialBookmarkingFunctions.php(23): social_bookmarking_get_services()
#3 /home4/nolacity/public_html/nolacitymuseum/plugins/SocialBookmarking/SocialBookmarkingPlugin.php(46): social_bookmarking_get_default_service_settings()
#4 [internal function]: SocialBookmarkingPlugin->hookInstall(Array)
#5 /home4/nolacity/public_html/nolacitymuseum/application/libraries/Omeka/Plugin/Broker.php(145): call_user_func(Array, Array)
#6 /home4/nolacity/public_html/nolacitymuseum/application/libraries/Omeka/Plugin/Installer.php(128): Omeka_Plugin_Broker->callHook('install', Array, Object(Plugin))
#7 /home4/nolacity/public_html/nolacitymuseum/application/controllers/PluginsController.php(77): Omeka_Plugin_Installer->install(Object(Plugin))
#8 /home4/nolacity/public_html/nolacitymuseum/application/libraries/Zend/Controller/Action.php(516): PluginsController->installAction()
#9 /home4/nolacity/public_html/nolacitymuseum/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('installAction')
#10 /home4/nolacity/public_html/nolacitymuseum/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#11 /home4/nolacity/public_html/nolacitymuseum/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#12 /home4/nolacity/public_html/nolacitymuseum/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#13 /home4/nolacity/public_html/nolacitymuseum/application/libraries/Omeka/Application.php(79): Zend_Application->run()
#14 /home4/nolacity/public_html/nolacitymuseum/admin/index.php(28): Omeka_Application->run()
#15 {main}

There should also be a message above this list giving the Notice or Warning with a few lines with details about it. Could you include that, too?


This is all it says above it:

Omeka has encountered an error

String could not be parsed as XML

I also just upgraded our server to PHP 5.3.25 if that helps any. I can give you access if that would help as well, since all plugins are creating this problem.

Heh...yeah that was completely a fail on my part. Sorry about that.

I'm pretty sure that the new version should fix that bug:

Looks like that solved the problem. Plugins are installing.

I just had the same problem after installing one of the bundled plugins (COINS). I tried deleting the plugin via FTP, but the Omeka install still won't load.