I am giving Omeka another go after suffering through an unsuccessful migration across platforms and 22,000 items needing to be redone. Pardon staring off like this but it is important to add context.

Am now facing a systemic unsuccessful series of videos and using Omeka to display them, to play them, with and without using the HTML5 plugin.

Super simple question. Can anyone recommend savings parameters for video files that will end up playing nice with Omeka? I have gone through a litany of Save As methods in Linux and Ubuntu and no matter what I do, the HTML5 player does not convert and play, anything.

I am on GoDaddy hosting platform. I have saved, well, in a litany of methods. I can list them all but that would be boring. Instead, can anyone provide a method to save a video file and have it play, nicely?

Additional context. I have a gobfull of videos to present. The most recent... Obama mentioned my father in a speech on Saturday and it would be nice to pull down this video file (already done), splice and merge the portions of the speech (also done), save them as .mp4 and a slew do variations (also done), and NONE of them play in Omeka.

I really wanted to give Omeka another go, and pressing forward after having to face 22,000 objects is not small. I started this again... but facing this ability to present videos yet again presents the delicacy of Omeka... I'd like to make this successful as I present to others and make recommendation, but after years of trying to finesse Omeka to have it perform, well... help me make this successful please. I wait to give the benefit of time and development. But this most straightforward task at this stage of the game should not be causing so much grief.

Sorry for the blitz. But Omeka really needs some energy on some very core functions and figured I would come on strong and try, one more time.

Help???? Energetic help?? I can supply details, but figured I would start here.

To add slight insult to injury... I downloaded the file from 'as is', imported it 'as is' to Omeka, and while it played quite fine from the WH site, it failed via Omeka.

I am all ears to hear if I need to tweak the HTML5 plugin. I know there is much more to it. Still, to experience such delicacy, such touchyness in an application... things should really be more mature application than they are coming across. Is Omeka going to remain in development stage for how long?

Sorry to be less than enthusiastic. Omeka has promise. But when?

I had no problems getting video directly from the White House site to load and play in an Omeka installation with the HTML5 Media plugin. This was with Omeka 2, HTML5 Media 2.1, and viewed with Chrome.

The video was the MP4-formatted download from this page.

I don't really know anything about the specific videos you've tried, what browsers you've used, the versions of Omeka and the plugin, or specifically what happens with the videos you've tried besides that they are "failing."

Without more of that kind of information, I can't say much more than "works for me."

I just downloaded this video as MP4, added it to an item to a local Omeka installation, and it plays fine for me. I had to click on the thumbnail Omeka generated for the video to open the actual video, but it uploaded and played just fine, without the HTML5 plugin.

While you've provided quite a bit of detail about how you've found and added your videos, it'd be helpful if you'd explain a bit more about how Omeka is failing. Some questions:

* Does it actual create a File record associated with your Item when you upload the video?
* If it does create a file record, can you click on that file record to see the video?
* If it doesn't upload the file, do you get any error messages when trying to save the item?

Happy to help you work this out, but some more details would be more helpful. A link to your Omeka installation would be particularly helpful, too.

Hello. Tx for replying.

Here is a link to the same exact White House file.

I have tried it in several different OS's (linux/ubuntu, Windows XP, Win7), across Chrome, Firefox, Opera, I.E.....

Nothing works. You can see the embedded metadata on the page that gives further information about the media item, which is the same as apparently works for you guys.

I disable HTML5 plugin and still have issues.

The items, beacuse they are large, were added via a Dropbox. Does this make a difference? I have not found any FAQs, tutorials, info, saying otherwise??

Is there some path assignment, some supporting application or dependencies, something I need to test in the OS to make HTML5 work? I have searched for anything that references HTML5 but have not found anything to test for in the environment.

Further characteristics... I have changed themes and all exhibit the same behaviour. .jpg, .tiff render fine, from thumbs to full sized.

.mp4, .avi, etc, if you go to the following, drop down into Shanks Bootees, there are 4 or 5 .mp4, .m4v, .avi files. None of them present a thumb or anything to click on to view them at all. I then go to the admin back end and at least get a clickable icon but then it just spins with nothing being rendered, viewable.

If I go here (not the admin view, but the public view):

I see the video ready to play. It also plays fine when I click the play button. If you don't see this, my first guess is that you don't have the right browser plugin to play this, which I think for this file is Quicktime.

This does indicate that your files are getting uploaded correctly, and that they have associated File records in Omeka.

Your public items/browse template seems a bit odd, since I can't actually click on the item titles to get to their respective show views, to see how the files are listed on the Item record.

Can't speak for what's happening on the admin side, though.

I went to a completely different environment and finally got something to play. Having 4 different computers and multiples of browsers in each of them, couldn't believe it to be that unlucky to not have any of them play the videos.

As for the themes... these are the default themes for Omeka 2.0 series. I started from scratch. Had to. I have cycled through Seasons, Thanks Roy, Berlin. None display the ability to play a video on the public side.... but it finally worked from the admin side.

Is there a favourite theme somewhere that plays nice with video display/playing from the public side?

We can only see the public side pages for your site. Jeremy's link in the post above is a public-side link to a video on your site.

For both me and Jeremy, the video there works fine. The theme currently seems to be Berlin, but previously was Thanks, Roy, and was working fine there too. All the themes should work fine with the media player.

I don't know how to account for your differing results, especially since you've said you've tried multiple systems and browsers. For myself, the behavior is the same, and correct, on Firefox and Chrome, both on Linux.

I don't get it either. Why the differences. I did finally try a totally different environment/OS/browser, and it finally worked. I know media conversions are tricky. But 4 system failures was a bit of a grind.

As for the themes, again, head scratching. That has nothing to do of course with my client side. Have tried several themes and none display the ability to play a video. Again, dismaying to be fighting the technology. Sorry to be a downer but the prospect of having to muck through yet again another reconstitution of 22,000 objects is not fun.

I will bang on the themes and see if I can get the public side to display videos. Is the same whether logged in as admin or Joe Q. Public.

If I set up a separate Omeka install and added some content, could anyone from the Omeka team or outside, if they have admin access, be able to determine why when viewing from the public side, why things are not displaying completely?

I upload a video, with or without HTML5 Viewer, and there is no icon or box that displays to be able to view it. This was mentioned by someone above when viewing an installed site, that they didn't know why things where not displaying properly. I would be happy to set up a parallel site, populate it, give admin access, and try and debug this.

I had 22,000 objects in a prior site but no matter what I did, the migration failed. So I rebuilt the site into latest Omeka and have 4,000 objects in it, and am bummed to find myself wrestling with display issues now. I've changed themes, changed browsers, systems, etc etc... done a slew of things. The only thing that seemed to have hope was toggling the 'display empty fields' in the Theme settings. It would work, then decide to not work, which was unwieldy anyway because it is not realistic to have empty fields display in a record. That got ugly real fast.

Help anyone? I really don't want to have to switch asset managers, again... rather figure this out. tx

Info about behaviour... when I attempt to either Browse Items or Browse Collections, no matter how I come at it this way, I am unable to see the full record which includes viewing a video or set of videos associated with an item.

However, when I select from Recently Added Items, it does display the record properly.


When I search for an item and then select it, it displays properly.

And yes, all items and collections are set to be viewable by the public.

Have you changed your items/browse page in the theme? Somehow the path to the item page, from items/browse goes to a type of search results page, when it should be going to an items/show page:[0][element_id]=50&advanced[0][type]=is+exactly&advanced[0][terms]=DSCN3510.JPG

That won't happen with the Seasons theme out of the box.

Hello. THANK YOU for responding. I had not seen this in the URL but it makes sense. No, I did not change anything. This is a stock Omeka fresh install of v2.0.3, and default themes that work for this version of Omeka.

Are you saying I need to recode something in the source for this to work? I need to ask because I do not have a clue where to change this from a 'browse' to a 'show'. Is it done in the source? Is it done in admin settings? I have rooted around but cannot find reference to this.

By the way, it acts the same regardless of what theme I select. I do not recall now if I dnloaded and put into place the Seasons theme... or if it comes as the default install of Omeka.

Tx. It would be cool to resolve this.

By any chance do you have the Search by Metadata plugin installed, and have selected the Dublin Core title? If so, unselect the title field, save changes, and try again.

Finally... I went back and deactivated practically every plugin. I did not have that many. I do not know which one was conflicting, but finally when Browsing Items and Browsing Collections, it points to the record. It did not exhibit this behaviour for anything except videos.

Am slowly bolting things back together and may find the offending plugin and will report. I'd rather have few things working but at least working, than not.

Tx for your reply. I am sure something else will crop up. I am so gunshy about upgrading that, well, will see.

Posts crossed each other. Perhaps that plugin was it. I had disabled it entirely, but as you mention it, will go back and reset as you state to see. tx tx

Your recommendation worked. Mebbe that was the culprit. Never wouldda found that one without just disabling. tx tx tx

It might be a good idea to slowly install plugins, test the site, so that if something happens it is much easier for trace back your steps to identify potential problems.

Yes. I always do that but this quirk snuck in. Just glad that it unraveled finally in a good way.

Off topic, but what is the largest collection in terms of items that you are aware of? Just curious...