Guest User: issues

Hi, I'm using the Guest User plugin in combination with the Contribution plugin to collect user content on a client's site. We've noticed a handful of issues and just wanted to put them out there to see how best to proceed.

  1. The lack of an option to configure the "instant access" duration. This would be a really useful addition in general, and especially so considering that one of the Guest User plugin's best uses is to enable the Contribution plugin. Users frequently need more than 20 minutes to compose a contribution and don't respond well when they lose their work.
  2. The link in the confirmation email doesn't appear to work during the instant access period (that is, when the user is "logged in"). It just lands the user on the homepage. At least on our site (which uses a custom theme and is served over SSL).
  3. When the confirmation link does work, it redirects to the GU login page with the message: "Please check the email we just sent you for the next steps! You're almost there!" But that step (clicking the confirmation link) has already been completed. The second message in the user's inbox is, for confirmation/login purposes, totally superfluous. It's just a confirmation of confirmation (which is fine to do but it strikes me as sort of confusing to tell people to go look at that and then come back).
  4. The inability of guest users to logout via /admin/users/logout. Is there some other way to accomplish this?

Many thanks!

1. Agree that a configuration for that duration makes sense. Should be an easy config option in Guest User.

2 & 3. Will look at the messages and links in those permutations. As of when I post this, is instant access on on the site, or is it turned off until these get sorted out? When I signed up, it looked like it went through the non-instant sequence.

4. That might be just changing the link. It's not much used in Omeka, but there's a public login and logout page. Using /users/logout instead of /admin/users/logout in those links might do the trick. Unless, of course, GU is creating those, in which case another fix for me to work on!

Thanks Patrick, I updated the log out link and it works great (I had hard-coded those, so it was not really a GU plugin issue after all). I have turned off instant access, but let me know if you're unable to replicate the problem on another site and I'll get you some more info. Cheers -- E