Gibberish after upgrading to Snow Leopard

I have Omeka running on my MacBook. After upgrading to Snow Leopard (and fixing the PHP/MySQL connection by adding back a php.ini), I was greeted with gibberish upon loading the Omeka site in my browser. This happened with the front-end and the admin site. The problem seemed to be with SL running version 5.3.0 of PHP. (It broke other software as well.)

After searching the forum, I found this thread, which describes a similar problem. The solution, described here, is to comment out lines 26-30 in paths.php. So, this...

if (extension_loaded('zlib')) {
ini_set('zlib.output_compression', 'On');
ini_set('zlib.output_compression_level', '5');

should become this...

// if (extension_loaded('zlib')) {
// ini_set('zlib.output_compression', 'On');
// ini_set('zlib.output_compression_level', '5');
// }

I did exactly that and upon reload everything went back to normal.


Spoke too soon. Omeka runs fine, until I try to write to the database. When I try to edit an entry (or add an item), I get this error:

No data supplied for parameters in prepared statement

I thought maybe this was due to something wrong with my installation, so I tried setting up a new install. On the first page (/install), it gives the me the same error.

Any ideas?

Whoops, the full error is as such:

Mysqli statement execute error : No data supplied for parameters in prepared statement

Hi Sandy,

Looks like you're experiencing the same error as this:

We'll bring this up at our next developer meeting, and I'll keep everyone posted on any temporary or long-term solution.



Has there been any progress on resolving this error?


There's a new release due out this week that will fix this error.


I'm having this issue ('gibberish' on install) on CentOS 5.3 running PHP 5.2.10 as well. I will try rolling back to 5.2.6 to see if that seems to rectify the problem...

drexellib: Santheo's fix above (commenting out the lines of code) should work. Also, expect a new release of Omeka soon that fixes this and has been tested w/ PHP 5.3 as well.