getting the 'contribution' plugin to work


I am starting work with omeka for a university project, I have got omeka running on my hosting space and it is going ok apart from the main function I was hoping to get. Adding Items to my archive via the front end is very important for what I am doing, I have downloaded the 'contribution' plugin which is supposed to allow me do this. I have done everything I am supposed to do to get it to work but it does not seem to be working. It has allowed me to upload a story but not with the proper process.

I get this error when I try to upload the other file types

'Sorry, this page doesn't exist. Check your URL, or send us a note'. you can check it out at ''

any body know what I have to do to resolve this problem?

The contribution form, after posting the data successfully is improperly redirecting users to the thankyou page. Notice how the URL you receive a 404 error page at is contribution/contribution/thankyou. If you were to remove 'contribution/' from the URL, you'll be successful.

What version of Omeka are you running, 0.9.0? And is your server up to date, PHP 5.2+?

I am running version 0.9.0. I made sure what omeka requires was available before i bought the hosting space from siteground. I am also using PHP 5.2.

yes the solution works but when trying to add the other types of files i get this error again 'Sorry, this page doesn't exist. Check your URL, or send us a note', and when i deselect 'story' and select it again I get the same error as the other ones. what an I missing?

thanks for the swift response by the way!

problem solved! I removed 'contribution/' from var uri = "<?php echo uri('contribution/contribution/'); ?>" + partial; in the add.php, so now it redirects to the page. thanks Dave

it allows me to upload files and documents but it won't allow me to view it, when I make contributions 'public' I get to see the description of the uploaded file and not able to view the file itself. my server admin has PHP 5.2 and ImageMagick installed on a Linux server. am I missing any thing to not be able to view the uploaded files?

I also continue to have trouble with the contribute plug-in. I just tested it now with Omeka core and the newest Contribute (0.9.0). When I submit an object of type "Story" it seems to work okay. But as soon as I switch Story to another type (Image, etc.), the "Your Story" field disappears and is replaced with a block showing a Search screen and "Oops!" page not found. It's like the system is not finding the block of code/HTML needed to display the appropriate field and button to let users browse for and upload a file. Any ideas?

Keep up the good work, and thanks!

Great catch, dawit. I didn't fully understand your response until I saw the additional contribution/ was actually added in the source code. Thanks.

An updated copy of the plugin is now in the plugins directory, and a brief description of the problem was shared on the developer mailing list:


Dave (and dawit), fantastic work - the updated plug-in seems to be working fine for us now, too. This was a big issue for our migration, so I'm delighted that this has been resolved. (And so easily!)


We are using the newest version of Omeka and the newest version of Contribution, but are still having the errors mentioned previously in this topic. On our screen it looks as if it is adding the header in the middle of the page when switching between story and file types. It is also directing to the wrong url for the thank you page. I have checked and the add.php file does not have the extra /contributions.

Is it possible to share a link to your Omeka installation so I could see exactly what's going on?

I was able to fix the thank you page. But, haven't located the problem with the contribute page with switching between submition types. Sadly, our Omeka installation is on a local server set up behind our campus's firewall on a subnet.

I've been doing all of my testing in Firefox and when I tried in IE, I get a different error all together. When I change the Contribution type in IE, it does not change the input panel at all. Though on both Firefox and IE, if I hit the submit button before filling in all of the fields, the screen is setup properly after it reloads.

Okay, I fixed it now. When trying to fix the Thank you page, I deleted a "/" that was needed on accident and placed it back where it belongs. Sorry for any inconvenience I may have caused.

I am experiencing the same problem :-(. I tried to modify the add.php file as earlier posts mention, but it has not helped. As far as I can see, it appears to have the correct URL with just /contribute .

I have Omeka 9.2.2 with the plugin downloaded today. My Omeka install is at .

I have two problems.
1. When a story is contributed, then the thank you page URL is contribute/contribute/thankyou . Fixing it manually to contribute/thankyou will display the correct page.

2. When a image is selected as contribution type, then I get an error after submission that Omeka has experienced an error.

Thank you for all your help!


Here is a bit more information about the problem.

The error #1 appears to have something to do with me serving the site from root url. If I change the site to example/omeka, then adding a story works fine.

The error #2 had to do with me not having write enabled directories inside the archive directory. Once I write enabled the directories, I have been able to add an image without an error.

It would be nice if the contribute plugin would work with the root URL site.

Thank you,

Hello, I am still experiencing an error with the contribution plugin. When someone uploads a story or a file and they agree to the consent form, the next page cannot be found The URL displayed becomes The line that was causing problems as noted in the previous thread add.php file in my case is following:

var uri = "<?php echo uri('contribution/'); ?>" + partial; .

The contribution plugin works correctly if I access the site by .

How can I fix the contribution plugin to work with a root URL?

Thank you,

Hi Tonu,
We apologize that no one has responded to this question yet.

We are stumped at the moment since this problem was solved with the newest version of the contribution plugin (0.9.1) and of Omeka (0.9.2). But, our developer who created that plugin is on vacation, so unfortunately you may have to wait a couple of weeks before this can get fully investigated.