GeoTiff on Geoserver and using gdal: Problem with file?

I am trying to use a custom map in Neatline (we are using Omeka 2.1.3 and Neatline 2.1.1), and as I understand it I need to send it through Geoserver to do so. When I try to upload the .tiff file, though, I get this error: "Could not list layers for this store, an error occurred retrieving them: Failed to create reader from file:data/propkartaGEOREF.tif and hints null". (I was able to create a store using a .tif file that had been preloaded into the directory, so I think I'm following those directions correctly and it is indeed a problem with the file.) I found a forum post with the same problem ( which seems to have been resolved through gdal_translate.

I must be doing something wrong in gdal (this is very possible, as I'm not even remotely close to a computer programmer), but I keep getting error messages saying that my file "does not exist in the file system, and is not recognized as a supported dataset name." I have the file in the root directory for OSGeo4W (and this worked last week when I was trying something with a test file). Might there be something wrong with my .tiff file? I also tried it with a .tif file, and that gave me the same issue.

I hope this is not a wild goose chase, but it seems like I probably need to rebuild the Geotiff in order for it to work properly in Geoserver. Am I missing something?