Geolocation -- locations not displaying


I recently noticed that on our public site, the map generated by the Geolocation plugin is not displaying any of the locations associated with our items. When I am logged in as admin, the locations do display just fine. They also display correctly on the map within the individual item records.

I installed the plugin several months back, but only noticed the blank map today.

This is the code in the items/show.php file:

<?php echo geolocation_google_map_for_item($item,$width='250',$height='250'); ?>

I using v.1.1.

Thank you for your help.

I'm having the same issue. It works fine on admin map tab and items, but won't work in either place on public side. All the items are public and it creates a space for the map, but no map.

public map browse


Ok, it is something in my custom theme that is causing the map not to show. It works if I switch to a default theme. But I'm running out of things to debug in my theme. I made sure if is loading the default.js so that Prototype library is loaded, which I believe is required by the plugin. I keep comparing the generated html source for the pages and they seem good, so I'm at a bit of a loss for right now.

My error console says that "OmekaMap is not defined" on my public item show pages and map/browse. Any thoughts?

First, try temporarily disabling ImageAnnotation. I noticed some javascript errors there in the browser error console.

Which version of Geolocation are you using. I tried using Geolocation 1.0-1.1.1 and it seemed to work for me when I viewed the public site as a non-admin.

I'd like to revive this issue. I also see the "OmekaMap is not defined" error and a blank map when running my server under the built-in Snow-Leopard Server on the Mac Mini (both admin and public). No errors when I test it running the MAMP server. I'm convinced it'll turnout to be a rewrite problem, but haven't figured out the missing rule yet.
Geolocation version: 1.0-1.1.1
Omeka: 1.2.1

Seems to be solved in the latest version (Omeka 1.3 with the new Geolocation 1.3). The downside for us is that it now uses Google Map API version 3, and we can no longer have Google Earth map tab as we used to in V2, by simply adding a;
in the initialize function in
Hopefully Google will reinstate the option in later releases.