geolocation configured but no pins appear

Hi Administrator: At, I'm creating an exhibit using Omeka 2.4 and the geolocation plugin 2.2.3. I've loaded 90 items 85 of which are diplomatic transcriptions of letters by Byron or of one sent to him between 1809 and 1811. The geolocation plugin worked seamlessly for the downloading of the first 68 letters. For the next 20 the geolocation feature has not appeared on either the edit or the public pages. And, of course, no new pins have appeared on the map (with the previous 68). I checked the configuration of the plugin and re-read the documentation. No luck, and the geolocation is the essential feature of the project. Thank you for help. Be well ...Paul

When you add the geolocation in item/edit, it sticks, but it doesn't display when you view the individual item on either the admin or public side? Or is it just not displaying on the browse map?

What do you currently have set under number of locations per page on the Browse Map settings of the plugin config?

Thank you for your quick response!
In item/edit the "map" tab appears (at the upper right hand corner) and I click on "find" once I have entered the address or the geo coordinates. The newly added item does not appear on either the admin or public side (as they did previously). The new 20 or so items do not appear on the browse map.
I have "100" on the locations per page in the plugin config
Be well ....Paul

What happens if you change the number of locations per page to 20 or 50?

Also, I see that you're using Embed Codes and PDF Embed (I think?) - did you install these or any other plugins about the time when the pins stopped displaying?


I tried re-configuring the plugin to both 20 and 50 and ran a couple of tests, but no change.

I have not installed nor deleted any plugins since the troubles began.

Be well ...Paul

So, to recap: the Map tab appears on the form and you can type an address, but when you save the item, no location appears on show, browse, or if you go back to edit the same item. In other words, the location isn't getting saved.

Have you tried using a different browser to edit an item to see if the results are the same?

Your recap is correct, with the exception that if I "search" a location (by city, say) in browse Maps, I will find items saved but not appearing on the map. So there is a partial save somehow, unless the search scans words in the body of the item.

I will try another browser other than Safari but I will not be able to report the results until tomorrow, 29 April.

Thank you and Be well ....Paul

Good Morning:

I used Google Chrome this morning. I clicked on the "Map" tab, entered the location (by address first, then by geo coordinates), then clicked on "find." As soon as I clicked on "find" a blue line appeared around the find tab and remained in view, frozen. I went ahead and saved the edit and no geolocation appeared on the admin or public page. Once this geolocation problem is fixed and my 120 letters downloaded, I want to experiment with Neatline. So the geolocation aspect is essential to the project.
What I don't understand is why Safari worked so well until 20 Feb 2016 and now doesn't.
Thank you and Be well ...Paul

Firefox doesn't work either. No blue line around the find tab, however.

Be well ...Paul


Is there a way that I could send you a file in order for you to take a look at it? It must be difficult for you to understand what's going on from my verbal description only.

Be well ...Paul

In your test by searching, is this on the admin side, using the 'Geographic Address' field, or on the public-side search box.

If on the public side, that will be a bit misleading, since as you guessed it does search all the metadata (thus is a match for searching 'London', because 'London' is in the description).

Not sure a file will help at this stage, but if you could give examples of addresses that do and do not work, that might help us track down what differentiates them.

Something that may shed some light on the problem: trying to do a search that does use the actual location information is causing an error: see this example search.

If you follow the linked instructions from that page for enabling the display of error messages, the resulting message might give a clue as to what's going wrong.

To answer Patrick's question, from the admin side > browse items on the map > search items > enter "Chepstow" as an example, and up comes the most recent letter I've downloaded (but failed to geolocate).

John: I will go to the error page and follow the linked instructions tomorrow morning 2 May.

Many thanks to you all! I very much need to get this fixed!

Be well ...Paul

Hey John and Patrick:
I managed to get to the public_html folder in Reclaim Hosting with several of the files such as, license.txt and db.ini., but I can't find the .htaccess file in order to edit it. I took a screenshot of the folder to show you but I can't include it in this post. The public_html folder has many sub-folders one of which is plugins which includes Geolocator.
If I perform a search in "All your files" of Reclaim Hosting for .htaccess, the search returns "/public_html/.htaccess" and I've yet to find the specific .htaccess file in order to edit it.
I'm close but suggestions?
Thank you, and Be well ...Paul

CPanel's file manager in Reclaim has a checkbox for whether to show hidden (dot) files. Make sure you've checked that box, and you should see .htaccess.

Thank you Patrick! I found the hidden file and edited it by unchecking the # at line 14.
I just now tried to geolocate Athens in Item #84 Byron to Stratford Canning, from Athens, October 13th 1810. I don't see any change in the admin or public views. I hope that you now have access to an informative error file.
Be well ...Paul

Can you share the contents of your System Information page? (It's accessible from the bottom-right of every admin page.) That will give us some useful information about what's installed and what the versions are.

Right. Excuse me for the delay. I've copied the contents of the "System Information." I hope that it helps! Be well ...Paul

Browser Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/601.5.17 (KHTML, like Gecko) Version/9.1 Safari/601.5.17
Role super
Omeka 2.4
PHP 5.5.30 (cgi-fcgi)
OS Linux 2.6.32-604.30.3.lve1.3.63.el6.x86_64 x86_64
MySQL Server 5.5.49
MySQL Client 5.5.49
PHP Extensions
Regular bcmath, calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, intl, ionCube Loader, json, libxml, mbstring, mcrypt, mysql, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, pgsql, Phar, posix, Reflection, session, SimpleXML, sockets, SourceGuardian, SPL, sqlite3, standard, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend Guard Loader, zip, zlib
Zend the ionCube PHP Loader, Zend Guard Loader
Coins 2.0.3
DocsViewer 2.0
EmbedCodes 1.0
ExhibitBuilder 3.3
Geolocation 2.2.3
Neatline 2.4.2
NeatlineFeatures 2.0.5
NeatlineSimile 2.0.4
NeatlineText 1.1.0
NeatlineTime 2.0.4
NeatlineWaypoints 2.0.2
SimplePages 3.0.7
TeiDisplay 1.0
berlin 2.3.1 (current)
default 2.3.2
seasons 2.3.1

Does disabling NeatlineFeatures help at all? We've had some reports of incompatibility between that plugin and Geolocation.

I deactivated NeatlineFeatures and the Geolocation WORKS! You folks are brilliant! I won't try reactivating NeatlineFaetures until I'm ready to use it.
Copious thanks, and Be well ...Paul

Good to hear!

The search problem should be resolved by upgrading Geolocation to the just-released version 2.2.4.

Thanks John! I'll have to re-teach myself how to upload the newest version of Geolocation. Be well ...Paul