ftp uploads not visible in omeka admin


I had been successfully using Omeka for a few weeks: changing themes, uploading files via dropbox, adding metadata etc. Then suddenly nothing I FTP'd through dropbox was visible in the Omeka admin. I was able to SCP files, so that temporarily solved that problem. However, now I am trying to change a theme, and have uploaded the theme folder to my server via FTP, and again, it is not visible in Omeka admin. I have given it a few days, and still nothing. I've tried two different FTP clients, but no luck with either. I can't recall making any change that would have caused this. Any ideas? I'm about to re-install Omeka entirely if I can't solve this problem.

Suggestions appreciated!


Probably no need to reinstall Omeka at this point. It seems like a file permissions issue, where the files you're uploading cannot be read by the browser. Can you check to see what the file permissions are in your themes, or in the Dropbox, and post those permissions here? Your FTP client may be incorrectly setting the file permissions. They need to be readable for Omeka to be able to find and use them.

You may also want to check with your host and/or system administrator, to see if any settings on your server have changed.

Hi Jeremy

Thanks for your response. I've checked the permissions for these folders. They were set to 755, and I changed them all to 777 rwxrwxrwx. Still not working.

I'll try checking with my host as well.

Thank you!

kvanmalssen: Do let us know if its something with your host. Good luck! If its not, we'll keep trying to help.

Hi -

Here is the response from the host:

"First, please
do not set *any* files to 777 permission on DreamHost servers. Irrespective of what you may have been told, this is never necessary here
as we run suExec, and setting files with 777 permissions is a serious security risk.

You might check to make sure that you are using the same FTP user to upload the files as the user the CMS is running under suExec "as" (with
whose permissions the CMS runs).

You can check this by viewing the domain on the Manage Domains screen of the web control panel (you will the user for the domain there). You might want to let the tech support folks at Omeka know you are running suExec; that might give them a clue as to what the problem might be."

Does this give you any ideas? I am using the same username to upload and log in to FTP.


I'm having a similar problem. I've installed the Dropbox plugin but when I click the Dropbox tab, NOTHING appears except for the Omeka admin navigation bar. I can view the files I've uploaded on my server (example http://dev.library.uaf.edu/omeka-1.0/plugins/Dropbox/files/P36.jpg), but I can't do anything with the files after selecting the Admin => Dropbox tab per Dropbox instructions.

What version of Omeka and the Dropbox plugin are you using?

Have you checked the permissions for the Dropbox/files directory? The files must be readable in order for Omeka to find them. It's possible that the public server settings have been reset or changed without you knowing.