filterSearchRecordTypes in Omeka 2.0

I'm trying to add a new record for searching, which is described at

But i'm not able to see the new record type. I expect it to be visible in the search dropdown (in hte upper right corner) on every page in the admin interface. Am I incorrect that it should show up there next to "Items", "Collections" and "Files"?
I tried to install the Simple Pages plugin, which also adds a new record type for the search, but that is also not showing up next to the three listed object types above. Is something broken or have I totally misunderstood it?

I tried to search for the default page title and that didn't come up, so I guess the Simple Pages search addon is not working either. Is it working for you?

You have to activate the new search types in admin/settings/edit-search

Then it will be working. It's now working for me.

After re-indexing the search (on the same page above) the Simple Pages search is working too.

Case closed, but maybe one could make s small note on the documentation page that the new search type need to be activated?

Glad you figured it out. I added the documentation you requested.