File upload of a text file fails since Omeka thinks it's text/x-pascal

Here's the contents of the text file (transcription of a letter):

Miss Madeline G. Howe
Parker Road
Wakefield, Mass.
Sept. 16, 1932
Dear Alice:
You say you will be in today.
So will I. I'll be free from 12:15 to 2:00 presumable, as my program says. Monday I will be in only for the sixth and seventh periods. Perhaps we can meet sometime today.
I don't have any idea when I will be out except this afternoon. Maybe in a hour, maybe longer.
I'll tell you what some of my funny looks are, so you will know me, perhaps when we do meet. I've red hair, (one up.) fairly tall, and wear glasses. Today I have on a brown dress with a light cream top - ??lk sport shoes.
Post me a note if you can make it today and tell me where to meet you.
Here's hoping!

Sometimes, particularly for text files like this which are unpredictable, PHP mis-detects the type of the file, like you're seeing here. In this case, it's probably the word "program", which occurs in Pascal source files, that's triggering this problem.

There's a few different possible solutions:

-Most easily, if you're dealing with just one or a few files, is place the text in the item's "Text" field (you'll get this field if you pick the Document item type), rather than uploading the text file. This will also allow Omeka to display the text for the item, not just link to the text file, and it avoids the type detection problem entirely.

-You can add "text/x-pascal" to your list of allowed MIME types. You'll find this in the Security Settings tab on the admin Settings page.

-You can temporarily disable MIME type detection for uploaded files. This is also located in Security Settings, you would check the box labeled "Disable File Upload Validation". I would recommend that you re-enable the file upload validation after you've dealt with your problematic files.