File Upload failed MIME type coulnd't be deteced for JPEG images


I installed Omeka todayon RHEL PHP5.2. When I try to upload a small JPG image I get the error message:

File Upload: The file 'untitled.jpg' could not be ingested because its media (MIME) type could not be detected.

Uploading .txt files gives no problems. I tried on Mac and Windows clients without succes. Any ideas?


Hi Patrick,

Ideally, that file's MIME type should be image/jpeg, which is on the list of allowed MIME types for file uploads. First, see if you can determine what the MIME type of the file is. If you find that, let us know what it is here.

Second, you can disable the file upload check by going to Admin > Settings > General Settings, then change the value of the checkbox near the bottom of the form for your General Settings. This isn't ideal, but it should let you upload the file until we can figure out what the issue with your file's MIME type is.


Hi Jeremy,

Thanks for the feedback. Indeed, when I do a mime type check (e.g. file -bI untitled.jpg) I get 'image/jpeg'. Same with other JPEG images on my computer.

When I disable the file upload check in General Settings, then everything works. The file is uploaded, a thumbnail gets created.

I tried different browsers on different OS with the same result. Do you know where I should look on the server to figure out which part of the code determines the MIME type of the upload?


Very weird. If you don't mind, could you send an email to the Omeka dev list, and attach that image to the email? I'd like to see if I can upload the image and get derivatives?

Also, you may have already done this, but make sure your path to ImageMagick is correct (and that you have ImageMagick installed on your server).

Sorry for omitting this. The dev listserv is here:

I had the same problem. Has there been any fix to this?

Hi kkeramidas,

Did you follow the same steps I and hochsten took to confirm that the file did in fact have a MIME type of 'image/jpeg'?

If so, feel free to send the image file to the Omeka dev listserv and I'll download it and see if I can figure out the problem.


I had a similar issue with uploading jpgs, either directly in Item/File tab or using DropBox. Got the error "The file 'test.jpg' could not be ingested because its media (MIME) type could not be detected." This only happened upon upgrade to 1.2 from .10. It worked once I checked "Allow header check" on the Security Settings tab. I can't remember what the default setting of that was upon upgrade, but it seems like it should default to checked. Otherwise, very nifty getting all the EXIF data and whatnot.

I had teh same isseu as above adn will sned my image, however, the work around was great for me! I have uploaded my logo

My version of Omeka does not have the checkbox to disable the file upload check.

Found it under security and it was resolved.

I am having the same problem. Tried to upload a .jpf file (jpeg2000 file generated by Adobe Photoshop). File upload failed because MIME type could not be detected. I added the jpf type in the user defined mime types of the server. Tried to upload the file again, but now Omeka is down and I am getting an Internal Server Error 500.

See below:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.16 (Unix) mod_ssl/2.2.16 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_bwlimited/1.4 Server at Port 80

Did uploading the file cause the error, or was there an error when you went to upload it another time? A file upload shouldn't cause an error.

You may have to check with your hosting service or webmaster, because there might be something else happening.

One other strategy is to change the security settings--mentioned above--and be sure to uncheck the box next to "Disable File Upload Validation."

I am receiving the same error message when I attempt to upload an image:

File Upload: The file 'x.jpg' could not be ingested because its media (MIME) type could not be detected.

However, I discovered that if I click "Add another file" and then click Browse next to the second "find a file" entry field, I am able to successfully upload the very same image.

I am having the same problem as many of the people above. The MIME type is not being recognized. I used the same work-around as loreesg. I went to add another file and used that browse box instead. It has solved the problem for now, but I too am interested in any fixes for this problem

I ran into the same error message when I tried to upload a logo in the customize theme area of the site. I checked the "Allow header check" on the Security Settings tab and I was able to upload the logo successfully.

As loreesg says, checking the "allow header check" seems to solve the problem. I didn't have to check the "Disable File Upload Validation". Just the "allow header check" to get uploads to work.

We've just encountered this issue after upgrading to 1.4.1 (We had been on 1.0 prior). I don't see an allow header check field on my security page... has it been moved elsewhere?

Related to your other thread (and the reason for the warning that Omeka now issues upon install), PHP's Fileinfo extension is more or less required for MIME detection to work with newer versions of Omeka.

The underlying library Omeka uses for much of its functionality removed the option that made our "header check" option work, so "header check" isn't available in Omeka 1.4 and up. Your alternatives are to install the Fileinfo extension, switch to PHP 5.3 (which includes Fileinfo by default), or disable MIME type validation entirely.

Can the need for fileinfo be added to the "Preparing to Install" requirements page?

Thanks for mentioning, it should definitely be noted on that documentation page.