File size too large - what things to change on Dreamhost


I am experiencing the problem are an individual archive item is too large per the Omeka FAQ below. However, I have no idea what configuration variables to change. Does anyone have any pointers for people using Dreamhost?

It is possible to change many MySQL settings among other values, but it is not clear what to change. I can see that "large files support" in ON. Any one know what else may need to be changed?

2. I'm getting an error telling me the file I want to upload is too large, what happened?

Please check with your server administrator about file size limitation. These settings are server specific and not imposed by the Omeka system. These limitations vary from server to server and we cannot change this for you. If you have a problem uploading files, please first check with your hosting service or your local server administrator



How big is the file you are trying to upload? There are 2 php.ini settings that could affect this, 'upload_max_filesize' and 'post_max_size'. You will have to adjust both of those (or get your server admin to do so) in order to accomodate the biggest files you expect to upload.

Your other alternative is to install the Dropbox plugin, which just means you will first upload the files to your server (most likely via FTP) and then use the plugin to transfer them to your Omeka installation.

You can try adding the following in .htaccess:

php_value upload_max_filesize 100M
php_value post_max_size 100M

The numbers are the size in megabytes of your largest items, plus some overhead. This will override the global php.ini settings, if your ISP allows that to happen. It may require an Apache restart, however, to load the new values.

It is also possible that you will need to play with max_execution_time and max_input_time if you have really large files and get timeouts on upload.

Hmmm... On my server, the settings are theoretically sufficient for a 100MB (or much bigger) file:
max_execution_time = 1200
max_input_time = 1200
post_max_size = 1024M
upload_max_filesize = 1024M

Yet, my users are still reporting the "Please check with your server administrator about file size limitation..." error message. Any idea what I might be overlooking?

themanwho, you're running 0.10. Correct?


Just a note: by far the easiest way to deal with this problem is to install the Dropbox plugin and use it, plus FTP, to upload large files. It's not tested with Omeka 1.1, only with Omeka 1.0, but so far it's working fine for me with 1.1.


I've just started experimenting with Omeka 1.4.2 which I FTP'd to DreamHost and find that a relatively large jpg of 1024 x 719 uploads OK.

For example, choosing an 'optimum quality' - ie File Size 194 KB - the jpg uploads with no problem; whereas 'best quality' - File Size 618KB does not. That's quite a big difference in terms of file size but the difference in quality is barely noticeable.

I've just uploaded a 1257 x 898 png file successfully - the File Size was 82 KB.

Presumably, DreamHost have a KB threshold...

Having said all that, the way to go is to follow the instructions for using the Dropbox plugin!

I've just FTP'd from the plugins/Dropbox/files folder on my computer a 2980 x 2091 8.9 MB png and then added it as an Item - ie File - from Dropbox.