File size limit?

I have been trying to upload a large pdf (165 MB). Are there any restrictions on file size?

I am having the same sort of issue. I am getting the error when trying to upload a 9MB file:

"filename.mp4 exceeds the maximum file size.0"

I looked through the forums and found the "File size limitation error" post, but this seems to be about something different, or at least the error message is different.

Is this something with the server, or is there anything I can do?

It is all about the requirements/limitations of your hosting server. Omeka, itself, does not limit file sizes.

One way to get around those kinds of restrictions is to install the dropbox plugin. This allows you to move files onto the server into the dropbox folder. They will be available from the admin side immediately and you can associate them with an item.

Here is a recent blog post about the dropbox:


Using Dropbox I'm able to upload it but no thumbnail is produced or displayed in Items and the document is not displayed in readable form by the DocsViewer plugin. The file is there for download.

Wanted to revive this. I use a tinkered-with version of Omeka 1.1 for my oral history website. I've been trying to upload video files via dropbox, but it seems to have a pre-set 150MB limit which I was not aware of. Double checked with Bluehost to make sure that it was not a limitation imposed by them, and it was not (we have larger video files than that on the website already). I am using an earlier version of the dropbox plugin, since updating the site to Omeka 2.0 is a longer term project than just getting some content up for the moment. Would updating solve any of these problems?

Pace 5-years-ago SheilaBrennan, this is definitely a part of Omeka 2.0. On /admin/items/add one reads clearly (sub "Add New Files"): "The maximum file size is 2 MB." I cannot find an admin setting where this limit can be changed.

This seems relevant:

It's the same in Omeka 2.0 as it was in older versions, it's just that we now read those PHP settings and tell you what the maximum is. Omeka's still not imposing a limit itself.

The post you linked to talks about updating the PHP settings. The part there about making those settings twice, once for PHP and once for Omeka, isn't necessary.

So, one can ignore the .htaccess components of the recipe?

You can see what works for you, since servers tend to have some variation in where PHP settings can be set. Bascially, though, you only have to set the settings in one place. php.ini is generally enough.