Fatal Error "Uncaught Exception 'Zen_Db_Statement_MySqli_Exception'

I've been trying to install Omeka on the server space I've bought for quite some time now, and I keep getting the following error message immediately after I type in a username, etc. and hit install:

Fatal error: Uncaught exception 'Zend_Db_Statement_Mysqli_Exception' with message 'Mysqli prepare error: CREATE command denied to user 'Harbourgirl355'@'' for table 'omeka_collections'' in /home/content/54/5077454/html/projects/application/libraries/Zend/Db/Statement/Mysqli.php:77 Stack trace: #0 /home/content/54/5077454/html/projects/application/libraries/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('CREATE TABLE IF...') #1 /home/content/54/5077454/html/projects/application/libraries/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), 'CREATE TABLE IF...') #2 /home/content/54/5077454/html/projects/application/libraries/Zend/Db/Adapter/Abstract.php(467): Zend_Db_Adapter_Mysqli->prepare('CREATE TABLE IF...') #3 [internal function]: Zend_Db_Adapter_Abstract->query('CREATE TABLE IF...', Array) #4 /home/content/54/5077454/html/projects/application/libraries/Omeka/Db.php(74): call_user_func_array(Array, Array) #5 [internal function]: Omeka_Db->__call('qu in /home/content/54/5077454/html/projects/application/libraries/Zend/Db/Statement/Mysqli.php on line 77

I've seen messages on these forums that contain some of the same phrases like "uncaught exception" and "Zen_Db" on these forums,and I've tried to check to see if any of the answers here will help with my issue, but so far I've had no luck, and since several of the messages appear to be about different issues or occur at different points, I suspect this may be a different issue.

I'd really appreciate any suggestions/guidelines. I'm using GoDaddy LAMP hosting, and their support has confirmed that everything matches Omeka's requirements and they are confused by the Zen_Db message.

I've tried reinstalling several times, I currently have version 1.2 installed. Any help would be most appreciated! Thanks!

As the exception indicates, your MySQL user does not have CREATE privileges. During installation Omeka attempts to create the required database tables; this is not possible, it seems, because GoDaddy has disabled the creation of new tables for your user, Harbourgirl355.

I would ask GoDaddy to enable CREATE privileges for your user for your Omeka database.

jsafley, thank you so much! you helped me immensely! i don't know if the issue was that the database was locked or the read-only username was used in the db.ini file, but after revisiting my settings, my Omeka installation is now up and working and i'm absolutely thrilled! thank you!

I received a similar error (but not related to table creation).

PHP: 5.2.13
MySQL/MySQLi: 5.0.89
Apache: 2.2.14
Hosting Service: Network Solutions

During the install process the tables are created (21 of them and 8 are populated). After I enter the basic site info (admin, email, title, etc.) the installation crashes with the following:

Fatal error: Uncaught exception 'Zend_Db_Statement_Mysqli_Exception' with message 'Mysqli statement execute error : Incorrect arguments to mysql_stmt_execute' in /data/18/0/140/114/792603/user/812185/htdocs/dr/application/libraries/Zend/Db/Statement/Mysqli.php:214 Stack trace: #0 /data/18/0/140/114/792603/user/812185/htdocs/dr/application/libraries/Zend/Db/Statement.php(300): Zend_Db_Statement_Mysqli->_execute(Array) #1 /data/18/0/140/114/792603/user/812185/htdocs/dr/application/libraries/Zend/Db/Adapter/Abstract.php(468): Zend_Db_Statement->execute(Array) #2 [internal function]: Zend_Db_Adapter_Abstract->query('? IN...', Array) #3 /data/18/0/140/114/792603/user/812185/htdocs/dr/application/libraries/Omeka/Db.php(74): call_user_func_array(Array, Array) #4 [internal function]: Omeka_Db->__call('query', Array) #5 /data/18/0/140/114/792603/user/812185/htdocs/dr/application/libraries/Omeka/Db.php(238): Omeka_Db->query('? IN...', Array) #6 /data/18/0/140/114/792603/user/812185/htdocs/dr/install/models/Ins in /data/18/0/140/114/792603/user/812185/htdocs/dr/application/libraries/Zend/Db/Statement/Mysqli.php on line 214

Based on other forum posts, I've verified my .htaccess and application/config/config.ini (added session.save_path = "/data/tmp") files.

My cgi-bin/php.ini contains the following:

register_globals = off
session.save_path = /data/tmp
mysql.default_socket = /tmp/mysql.sock
mysqli.default_socket = /tmp/mysql.sock

Anything I may have overlooked? All thoughts or suggestions would surely be appreciated. Thank you.