exhibit builder plugin error

I'm very new to omeka and trying to work with it on my campus with very little tech support. A tech person installed several plugins, but I'm having trouble using them. I want to use exhibit builder and myomeka this fall with students. When I click create an exhibit I get a page not found message. A tech person installed Exhibit Builder version 0.5.1 I'm not sure how to move forward with this problem.

What version of Omeka you are running? When you sign in through the /admin panel, you should see the version in the footer.

You also might want to deactivate the Exhibit Builder plugin and then activate it again. If that doesn't work, try uninstalling and re-installing the plugin.

The tech person installed 1.2.1 omeka this morning, we thought perhaps starting over with installation of the whole thing might clear up problems. The installation went okay, but when he installed exhibit builder it compromised the site...no settings access and numerous 404 errors. I'm trying to see if he or another tech person would be willing to participate in the forums since faculty don't have access to the campus servers/tech elements.

Once the Exhibit Builder was installed, where exactly did get the 404 errors? For instance, can you still log in to the /admin panel and add or edit items? Can you access the site's admin settings? You can include URLs if that is helpful.

Also try uninstalling the Exhibit Builder, version 0.5.1 and delete that from the plugins directory and install version 0.5.2.

Hello - I am the sysadmin that has been working with this issue. It seems that anytime that we activate the plugin the settings subsite and basically the whole site starts to fail to show with DNS errors. However it will let me continue to navigate to other areas of the site during the session until I log off in witch case it is entirely broken for access - unless I deactivate exhibit builder. I have reinstalled the application and disabled the plugin and all seems fine. I have tried uninstalling and reinstalling several times. I have deleted and replaced the files in the plugin folders. I have also tried and upgrade to the latest version of omeka. It seems like after I do a restore (install files) that if I try to browse or work with exhibits the whole system will fail - but if I disable it then it will work fine for everything else. Please offer any suggestions. Thanks

Hi ccomeka,

A few questions:

* Do you have a link you can share with us?
* Can you go to other pages in Omeka, like items/browse, items/show? If you can't, it sounds like it might be an issue with URL rewriting and the .htaccess rules. Make sure you actually have an .htaccess file in your installation, and confirm with your sysadmin that mod_rewrite is enabled on your server.


Hi ccomeka,

To follow up with my last post, please confirm whether you can visit other Omeka pages before *and* after you install ExhibitBuilder. And, does this happen with other plugins, or just ExhibitBuilder?


Hello Jermey
Thanks for the suggestions
Our site is http://omeka.cord.edu
I can get to all links until I activate the update after that it does not display the pages. I do have the .htaccess file copied over and present in /var/www (this came fresh from the new install pack) . I pretty much can only get back to the admin subsite (if I am in the same session) by hitting http://omeka.cord.edu/admin. I was thinking of just killing the DB in mysql but when I tried to drop it the response was: drop database omeka;
ERROR 1010 (HY000): Error dropping database (can't rmdir './omeka/', errno: 17)
Any suggestion on that approach?
This does occur when I install other plugins such as Site Notes, Social bookmarking, TOS, Timeline, but Coins, My Omeka, and Simple Pages give no issue.

I have since scrapped the server and started from scratch on this install - hoping this plugin issue will not come back. Thanks