Exhibit Builder and Error 500

We upgraded our site from Omeka 1.0 to 1.2.1 today, and upgraded Exhibit Builder up to 0.5.2, as well. The site seems to be working fine for the most part. However, we are having a problem with Exhibit Builder now. When I go in to create or edit a page in Exhibit Builder, I get Error 500 in a pop up window, and am unable to add or edit images on the page template. Editing at the exhibit or section level seems to work fine. We did not have any problems with Exhibit Builder prior to upgrading.

Could this be an Apache issue? Is there anything we should look for in this .htaccess file?

This 500 is written to the Apache access log. There is no message written to the error log, however. - - [06/Aug/2010:13:23:52 -0400] "GET /admin/exhibits/items HTTP/1.1" 500 2542 "http://exhibits.gelman.gwu.edu/admin/exhibits/edit-page-content/6" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)"

Hi David,

Did you also upgrade Exhibit Builder? I know you have a new version, but when you go to the Settings > Plugins page, you should see an upgrade button beside any plugins that have new versions. If you haven't done that, try it and see if it resolves the issue.

If you did do that, I'm wondering if there's an issue with file permissions on any of the exhibit builder files. This probably wouldn't cause a 500 error, but it wouldn't hurt to check.

Also, do you have this problem with creating new exhibits and/or editing existing exhibits?

What page and link are you clicking that generates the popup window? We don't have any code in ExhibitBuilder that creates new browser windows, so the fact that you're getting a new pop up window is very odd, and I honestly don't know what would be causing that specifically.

Hi Jeremy,

I'm pretty sure that Exhibit Builder is upgraded. I see no upgrade button, and it identifies itself as Exhibit Builder Version 0.5.2 . I can send a screenshot if there's anything you'd like to check.

We tried to rule out file permissions as an option. We briefly chmodded everything to 777 on our test instance, and were still getting the same error.

This issue seems to affect both new and old exhibits. It occurs every time we open the "/admin/exhibits/edit-page-content" template.

Popup was probably a poor choice of words, but I will send you a screenshot of exactly what it is doing. As I mentioned, this error appears immediately whenever we open the "edit" interface for individual exhibit pages.