Exhibit Builder 3.woe (Installs, but doesn't function.)

With a full release, I decided to give Exhibit Builder 3.0 another try. It did not go so well. I did backup my database, but is there a way to downgrade a plugin rather than restoring a backup? My old Exhibits display fine, but I've not dared to try editing them.

Here was my process:

  • Deactivate old plugin
  • Rename existing ExhibitBuilder directory
  • Unzip new ExhibitBuilder in plugins directory
  • Click the "Upgrade" button
  • Make sure my old content survived
  • Remove old ExhibitBuilder directory

..but then I tried to create a new Exhibit. The first page works fine (and I did try switching to a built-in theme here, but no dice). But when I go to "add page," things immediately look fishy. For starters, my new content block area looks nothing like the screenshot in the 3.0 documentation. There are some other oddities about that page, which are best described using an image (boy do I wish I could use dropbox at work!).

Image 1: https://github.com/sheepeeh/snippets/blob/master/omeka/forum-images/troubleshooting/eb3_ts1.png

The search form works, but the show/hide button is weird and does not, and the search results are wacko. Most buttons have no effect.

Image 2: https://github.com/sheepeeh/snippets/blob/master/omeka/forum-images/troubleshooting/eb3_ts2.png

Search results page: https://github.com/sheepeeh/snippets/blob/master/omeka/forum-images/troubleshooting/eb3_ts3.png

The source for the admin page and search page are there with the images.


Yes, those images are definitely not right. It does seem to be some problem with the CSS and/or Javascript for the admin side of the Exhibit Builder.

Do you get the same results on a different browser or with a different computer? I'm hoping it's just something simple like the old 2.x version of the Javascript being cached in your browser.

I don't know where my brain is that I didn't think to do that on my own.

Tried in Chrome, works.

Cleared Firefox cache, works.


Glad to hear it.

Exhibit Builder 3 is a pretty major upgrade to the way Exhibits are stored, so there's definitely room for unforeseen things to go wrong, even though we've tried to be pretty exhaustive in our testing.

In this case, the fact that your exhibits were showing up fine on the frontend was a pretty good sign that things were basically working correctly, as that's where the meat of the upgrade is, in moving from the old structure to the new.

I've also upgraded to 3.0 and seem to have lost all of my exhibits. Is there a way to get them back and just go back to the old exhibit builder?


It doesn't sound like your problem is related to the one in this thread.

You might want to create a new thread for your problem instead, and include a little more information about what you did and what went wrong. The upgrade to Exhibit Builder 3.0 doesn't really change anything about the table that stores exhibits, its changes are to the page and entry tables.

The entire Exhibits section would temporarily disappear when you uploaded the new files because Omeka deactivates plugins that need to be upgraded. Is it possible that's what you're seeing?

That is entirely possible. I simply downloaded the plugin, unzipped, and placed it in my plugins directory. I went to activate the plugin, and I see this inside of a green colored cell:

You have a new version of Exhibit Builder. Please upgrade!

There is a green "upgrade" button to the left where the activate buttons usually are.

When I click it, I get the:

"Omeka Has Encountered and Error"


I must be missing a critical step here, but just can't figure it out.


Have you followed the retrieving error messages instructions mentioned on that page?

That's always a good first step when you're seeing one of those error pages, as it gets you the more specific information about what's happening.

I am not sure about this...and now it's too late to replicate the problem but I had a bad upgrade experience going from ExhibitBuilder 2.x to 3.x. Twice. On closer examination (before the 3rd try on a clone install of what I had the first time around), I discovered that ALTER_PRIV was not set to "Y"..but I don't recall Omeka complaining about that...it just didn't work right once the upgrade was completed.

Since the exhibit table's get modified, I can see where this could easily have caused my problems.