Exhibit Builder 2.0 not appearing/site not appearing

I just upgraded to 2.0 and discovered the issue with plug-in incompatibility. After making sure I had 2.0 versions of the bundled plug-ins and everything else deactivated, the admin interface is fine but my site is still invisible. Additionally, Exhibit Builder does not appear on the interface and when I go to the plug-ins page, I get a message saying I need to upgrade it. I click the upgrade button but nothing happens. The page seems to refresh but the message is still there.

Things I have tried:

1. Changing the site theme to one of the 2.0 themes.
2. Deleting everything in the plug-ins folder and reinstalling the 2.0 plug-ins folder.

COinS works fine and so does Simple Pages. Exhibit Builder is the only one I'm having trouble with. Any ideas?

UPDATE: Fixed the public site problem by changing our theme to one of the 2.0 ones.

Exhibit Builder is still not working!

UPDATE 2: I figured out how to fix Exhibit Builder. Here is my solution in case other people are having the problem with the "upgrade" option displaying but no installation occurring:

Go to the plug-in folder and delete this line from the plugin.php for Exhibit-Builder:

add_plugin_hook('upgrade', 'exhibit_builder_upgrade');

Then log into the admin interface to make sure it's working and that the exhibits are there. That's all. I added the line back in to the plugin.php afterwards and it seems to have solved the problem.

You're having an error when ExhibitBuilder tries to upgrade.

Deleting the upgrade hook will get rid of the error, but it won't actually do the upgrade. You may see the exhibits, but they won't be working properly. You will likely see missing pages or entries, or have errors if you try using the Exhibit Builder further.

I have noticed this. I eventually ended up uninstalling the whole thing. What should I do next?

If you're fine starting from scratch on your exhibits, simply reinstalling the Exhibit Builder should work fine, since this is just an issue with the upgrade process.

If you're looking to maintain your preexisting exhibits, you'd need to restore a backup of your previous Omeka database (or just the ExhibitBuilder tables).

Then, you'd need to either try the ExhibitBuilder's code from Github, or wait for us to prepare an updated ExhibitBuilder which will incorporate the fix for upgrading.

Just so I understand correctly, is this a problem with Exhibit Builder for 2.0 or did I possibly do the upgrade incorrectly?

I restored our old site for the time being until I figure out what went wrong.

This is our fault; a bug in the Exhibit Builder 2.0 upgrade process.

We'll update the Exhibit Builder, and we'll probably have a new Omeka release incorporating that new Exhibit Builder and some other fixes. Then you should be able to re-upgrade from your old site without a problem.

I'd like to jump in to this thread, since I have also a problem with the ExhibitBuilder plugin. My problem is slightly different.
I was using the 2.0Beta version with ExhibitBuilder (from Git). I upgraded my installation to 2.0 stable by copying the new files to server (no install script). All I had to do was to update the Simple Pages plugin. I didn't have to update the ExhibitBuilder (maybe because I took the recent version 2.0.1 from Git).
All worked fine, untill I tried to reinstall the ExhibitBuilder plugin (this is my development server so I test many options here). So the plugin was removed properly, but now I can't install it again. I received an error with the SQL syntax.
Debugging a bit, I tried to run the SQL commands from the plugin install function manually. The first two run successfully, but the last one failed:

CREATE TABLE IF NOT EXISTS{$db->prefix}exhibit_pages (
id int(10) unsigned NOT NULL auto_increment,
exhibit_id int(10) unsigned NOT NULL,
parent_id int(10) unsigned,
title varchar(255) collate utf8_unicode_ci NOT NULL,
slug varchar(30) collate utf8_unicode_ci NOT NULL,
layout varchar(255) collate utf8_unicode_ci default NULL,
order tinyint(3) unsigned NOT NULL,
KEY exhibit_id_order (exhibit_id, order)
UNIQUE KEY exhibit_id_parent_id_slug (exhibit_id, parent_id, slug)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;

MySQL server returns the error:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'UNIQUE KEYexhibit_id_parent_id_slug (exhibit_id, parent_id, slug) )' at line 11

So I can't create the third table for the plugin.
Any ideas what is wrong?

MySQL server ver. 5.5.29

Ack, there's a missing comma there. Always some risk of little problems with unreleased versions, but this was just sloppy on our (my) part.

The updated code returns the comma to its rightful place in that query.

Wow!, I really missed it - it was too late to think yesterday, but not too late to post a message ;-)

Thanks for your help.