Exhbitor Plug in 404 error


I'm testing out the exhibit builder plugin. I loaded a test exhibit(with a Section and Page items.)

But I got a 404 error message when trying to view my public site. I am only getting the error message when I tried to view my exhibit all other buttons on the Omeka site work fine.

I also tried changing the config file to display errors in get so more detail about the problem ( in config.ini file I changed log error = true) But that caused the following error messages on all the entire Omeka site = "Error log file cannot be written to. Please give this file read/write permissions for the web server."

I am running a Exhibit Version 0.5.2 and Omeka 1.2.1. (I am viewing it on a internal server or I would seen you to the site.)


Let me know if you need more information!

The file application/logs/errors.log needs to be writable by the server when you have logging enabled. Basically, it needs to have the same permissions as you have set for the archive directory (which is also server-writable).

As for your underlying problem, are you getting a 404 on any other public-side pages, like '/items'? If you get a 404 on every public page but the home page, that's a pretty good sign that you're just missing your .htaccess file.

Thanks John.
I was missing that.htaccess file.