Error when trying to load an item.

Hi, I'm getting an error on my site on both the public and admin views:
Omeka has encountered an error
whenever I click on an item in the Browse Items page.

I checked the error log and the last entry looks like:

[16-Sep-2012 13:09:19] PHP Fatal error: Call to a member function getWebPath() on a non-object in /home/pw1/public_html/GVH/plugins/Zoomit/controllers/IndexController.php on line 11

I tried deactivating the ZoomIt plugin, but it did not work.

I haven't upgraded to 1.5.3 yet because I'm teaching a class right now, and didn't want to run into any issues, but if upgrading will fix it, I'll give it a try.

Thanks for any help! Cathy

What version of Omeka are you currently running?

Have you deactivated and uninstalled the plugin?

Hi, I am using Omeka 1.5.1. The Zoomit is 1.0. I did deactivate it, and just tried uninstalling, but I still get the same "Omeka has encountered an error."

When you try uninstalling, does it give an error, and, assuming you can get to the list of plugins, does it still show it as being installed?

I would only expect that error to appear on an item show page, and only if the plugin is installed and activated.

HI-- I did uninstall it. When I look at the plugins page, the option next to Zoomit is "Install" so I think that was successful. I did not get an error when I uninstalled.

huh. Are more of the same error piling up in your logs? If so, then I'm confused about how an uninstalled plugin would still be running.

From the original error, it looks like for some reason the plugin couldn't find the file associated with the item. With the plugin uninstalled, I'd hope for a different error to be logged.

The error log had lots more in it. I copied it here:

Sorry about the confusion!

Do you think that upgrading Omeka to 1.5.3 will fix this problem? The only thing I had recently done is install and activate the Neatline plugins, but I tried uninstalling them this morning and the error is still there.

Though I keep getting errors, the error.log hasn't been updated, it is still dated 9/24/12. I'm going to try the upgrade to see if that helps.

Alright, I backed up and then updated Omeka and got the same error. I turned on the error messaging and got this. It happens when I click on an item, whether from the home page or from the item list.

Omeka has encountered an error


Passed parameter is not a valid HTTP URI.

#0 /home/pw1/public_html/GVH/plugins/Scripto/libraries/Scripto/Service/MediaWiki.php(113): Zend_Http_Client->setUri(NULL)
#1 /home/pw1/public_html/GVH/plugins/Scripto/libraries/Scripto.php(77): Scripto_Service_MediaWiki->__construct(NULL, true)
#2 /home/pw1/public_html/GVH/plugins/Scripto/ScriptoPlugin.php(388): Scripto->__construct(Object(ScriptoAdapterOmeka), Array)
#3 /home/pw1/public_html/GVH/plugins/Scripto/ScriptoPlugin.php(304): ScriptoPlugin::getScripto()
#4 /home/pw1/public_html/GVH/plugins/Scripto/ScriptoPlugin.php(263): ScriptoPlugin->_appendToItemsShow()
#5 /home/pw1/public_html/GVH/application/libraries/Omeka/Plugin/Broker.php(156): ScriptoPlugin->hookPublicAppendToItemsShow()
#6 /home/pw1/public_html/GVH/application/libraries/Omeka/Plugin/Broker.php(182): Omeka_Plugin_Broker->callHook(Array, Array)
#7 [internal function]: Omeka_Plugin_Broker->__call('public_append_t...', Array)
#8 /home/pw1/public_html/GVH/application/libraries/globals.php(215): Omeka_Plugin_Broker->public_append_to_items_show('public_append_t...', Array)
#9 /home/pw1/public_html/GVH/application/libraries/globals.php(234): fire_plugin_hook()
#10 /home/pw1/public_html/GVH/application/helpers/PluginFunctions.php(92): get_plugin_hook_output()
#11 /home/pw1/public_html/GVH/themes/rhythm/items/show.php(26): plugin_append_to_items_show()
#12 /home/pw1/public_html/GVH/application/libraries/Omeka/View.php(113): include('/home/pw1/publi...')
#13 /home/pw1/public_html/GVH/application/libraries/Zend/View/Abstract.php(888): Omeka_View->_run(Array, Array)
#14 /home/pw1/public_html/GVH/application/libraries/Zend/Controller/Action/Helper/ViewRenderer.php(900): Zend_View_Abstract->render('public_append_t...')
#15 /home/pw1/public_html/GVH/application/libraries/Zend/Controller/Action/Helper/ViewRenderer.php(921): Zend_Controller_Action_Helper_ViewRenderer->renderScript('fire_plugin_hoo...', Array)
#16 /home/pw1/public_html/GVH/application/libraries/Zend/Controller/Action/Helper/ViewRenderer.php(960): Zend_Controller_Action_Helper_ViewRenderer->render('public_append_t...')
#17 /home/pw1/public_html/GVH/application/libraries/Zend/Controller/Action/HelperBroker.php(277): Zend_Controller_Action_Helper_ViewRenderer->postDispatch()
#18 /home/pw1/public_html/GVH/application/libraries/Zend/Controller/Action.php(527): Zend_Controller_Action_HelperBroker->notifyPostDispatch('/home/pw1/publi...')
#19 /home/pw1/public_html/GVH/application/libraries/Zend/Controller/Dispatcher/Standard.php(295): Zend_Controller_Action->dispatch('items/show.php')
#20 /home/pw1/public_html/GVH/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch('items/show.php', NULL)
#21 /home/pw1/public_html/GVH/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#22 /home/pw1/public_html/GVH/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#23 /home/pw1/public_html/GVH/application/libraries/Omeka/Core.php(165): Zend_Application->run()
#24 /home/pw1/public_html/GVH/index.php(28): Omeka_Core->run('showAction')
#25 {main}

I just deactivated Scripto and fixed it. Not sure what happened, but whew!

Whew, indeed! It might be something to pass on to the Scripto folks, though.

Will do.