Error When Attempting to Re-Index Omeka 2.0.2


When I try to reindex Omeka selecting all of the following categories:

Exhibit Page
Simple Page

I get an error:

[22-Mar-2013 20:22:09 America/Chicago] PHP Fatal error: Class 'Omeka_Plugin_Abstract' not found in /home/pna6fb9i/public_html/omeka/plugins/Commenting/CommentingPlugin.php on line 5

Why could this be happening?

It looks like you have a version of Commenting that isn't up to date. The official 2.0-compatible version hasn't been released yet, but if you are using what's on GitHub getting the newest might fix it.

On the other hand, just deactivating the Commenting plugin will take care of this immediately.

That actually reminds me of another issue. I was trying to delete Commenting since it did not work with 2.0+ and so I deleted the folder on my server however it is still listed on my Plugins page in the Admin section. Is there anyway I can actually get rid of Commenting (and hopefully solve problem #1 at the same time?)

That seems odd, since the error message indicates that the file is still there. Are you able to disable or uninstall the plugin? (keep in mind that uninstalling will delete all the comment data--be careful if you go that route)

No worries with deleting the comment data; it is a fairly new original install (post 2.0). I am not able to disable or uninstall the plugin since the folder is not still in my Plugins folder on my server. I could reupload it though. Do you think that might help?

I have done this. Once the files are deleted, you shouldn't get anymore Omeka errors.

The plugin is still listed after you delete the files if you didn't deactivate the plugins before upgrading. This is one reason why we recommend deactivating all plugins immediately after you backup your database before upgrading.

And you're right that the only way to get rid of the plugin's listing in your directory is to install the plugin (I'd wait for the 2.0-compatible version which will be available in early May), and then deactivate and uninstall. At that point, the plugin will not be listed in your directory.

Thank you for your help. Yes, I tried to re-upload the plugin but it created a server error and my Omeka site that it was configured incorrectly. Changing the name of the Commenting folder solved the problem so I will wait until May for the 2.0 compatible version to make things easy.