Error uploading one image file, not all

So I can upload several other image (.jpg) files successfully, but there is one file that fails every time. It is not larger than the max file size, so I can't understand why there is a problem with it. Below is the full error message we receive:

Omeka has encountered an error


ImageMagick failed with status code 9. Error output:

#0 /usr/local/library/omeka/application/libraries/Omeka/File/Derivative/Image/Creator.php(107): Omeka_File_Derivative_Image_Creator->_createImage('/tmp/7a9df1729f...', '/tmp/fullsize_7...', '-background whi...')
#1 /usr/local/library/omeka/application/models/File.php(362): Omeka_File_Derivative_Image_Creator->create('/tmp/7a9df1729f...', '7a9df1729fe4adf...', 'image/jpeg')
#2 /usr/local/library/omeka/application/models/Job/FileProcessUpload.php(22): File->createDerivatives()
#3 /usr/local/library/omeka/application/libraries/Omeka/Job/Dispatcher/Adapter/Synchronous.php(25): Job_FileProcessUpload->perform()
#4 /usr/local/library/omeka/application/libraries/Omeka/Job/Dispatcher/Default.php(136): Omeka_Job_Dispatcher_Adapter_Synchronous->send('{"className":"J...', Array)
#5 /usr/local/library/omeka/application/models/File.php(209): Omeka_Job_Dispatcher_Default->send('Job_FileProcess...', Array)
#6 [internal function]: File->afterSave(Array)
#7 /usr/local/library/omeka/application/libraries/Omeka/Record/AbstractRecord.php(277): call_user_func(Array, Array)
#8 /usr/local/library/omeka/application/libraries/Omeka/Record/AbstractRecord.php(550): Omeka_Record_AbstractRecord->runCallbacks('afterSave', Array)
#9 /usr/local/library/omeka/application/models/Item.php(322): Omeka_Record_AbstractRecord->save()
#10 /usr/local/library/omeka/application/models/Item.php(235): Item->saveFiles()
#11 [internal function]: Item->afterSave(Array)
#12 /usr/local/library/omeka/application/libraries/Omeka/Record/AbstractRecord.php(277): call_user_func(Array, Array)
#13 /usr/local/library/omeka/application/libraries/Omeka/Record/AbstractRecord.php(550): Omeka_Record_AbstractRecord->runCallbacks('afterSave', Array)
#14 /usr/local/library/omeka/application/libraries/Omeka/Controller/AbstractActionController.php(144): Omeka_Record_AbstractRecord->save(false)
#15 /usr/local/library/omeka/application/controllers/ItemsController.php(149): Omeka_Controller_AbstractActionController->addAction()
#16 /usr/local/library/omeka/application/libraries/Zend/Controller/Action.php(516): ItemsController->addAction()
#17 /usr/local/library/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('addAction')
#18 /usr/local/library/omeka/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#19 /usr/local/library/omeka/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#20 /usr/local/library/omeka/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#21 /usr/local/library/omeka/application/libraries/Omeka/Application.php(79): Zend_Application->run()
#22 /usr/local/library/omeka/admin/index.php(28): Omeka_Application->run()
#23 {main}

Any suggestions would be appreciated!
Thank you.

It looks like ImageMagick is failing when trying to create the derivative images. It's hard to guess what might be the cause, though. Can you open or edit the file in other image viewers or editors?

Yes, I can open and edit the files in other applications (photoshop, etc.). It seems this is happening only with scanned photos, as the tests we did with pre-existing jpgs (downloaded from our website and/or created in photoshop) worked fine. I'm wondering if extraneous metadata from the capture method(s) might have anything at all to do with it, though I can't find any information to support that. Otherwise, I'm not sure what the common denominator would be....

Update: How's this for interesting... If I restart apache on the server, I can upload the same image without a problem once or twice, but by the third (sometimes second or fourth) time I test it, it fails again. Curiouser and curiouser!

Keep in mind, I can still upload other image files as mentioned earlier, even after it bombs....

btw, I noticed we are on an older version of IM - 6.2.8 - do you think that matters?

Dawn, did you ever find a solution to this? I am getting the same error now for most image files that I try to attach to items, either by manually uploading or by using the Dropbox plugin.

Omeka has encountered an error

ImageMagick failed with status code 9. Error output:

We did resolve the problem. First, I reinstalled ImageMagick. I also had to change the path to it in web admin, because for some reason, in our installation, it did not reside in the default location. However, ultimately, we found we had to upgrade our server. We use an amazon cloud server (AWS) and we upgraded from a micro to a small instance (better processor, more RAM, etc.) Even though the micro server met the Omeka minimum requirements, it still failed on performance.
I don't know if this information will help in your circumstance, but hopefully it might spark something... Good luck to you!

So is this a server overload issue? Have other people had similar experiences to DawnRomano?

I was running Omeka 2.3.1 without any problems, then moved to a new server affiliated with my college. As soon as I did that, I started having the same error. Some files upload and create thumbnails, others do not. All our files are JPEGs, scans from a microfilm, and we found that if you keep on attaching the file and saving over and over eventually it does stick.

All the plugins are the same on both sites.

My sites are:

You might check with your sysadmin for the college site - it might be something in the settings for that server?