Error message regading "PHP fileinfo extension not found"

i first installed omeka 1.3.2 in , it was smooth and ok. when i found omeka 1.4 then i remove the 1.3.2 and install 1.4 but in install page it shows a error message. The message was regarding the "PHP fileinfo extension" was not found and it disabled some omeka options. i already install 1.4 but My questions are -

1. How it will effect the site and how to resolve (i intend to do a painting artist/bio archive) as i'm using a shared hosting.

Related server info:
cPanel Version 11.30.0 (build 32)
PHP version 5.2.17
Apache version 2.2.17

The Fileinfo extension is included in PHP 5.3, so switching to that will get rid of that warning. You can also install it using PECL for PHP 5.2.x.

What not having the Fileinfo extension disables is the validation Omeka would normally do on the type of uploaded files (we use a Zend component that doesn't work reliably without this extension). If only you or people you trust will be uploading files to the archive, then you're probably fine to leave this disabled.

Dear John: thanks for the info; for now i can live with that. But when i start searching for the extension i find ( ). i have PEAR Installer in cpanel, so how can i install this extension? In cpanel PEAR, it wants a package name in a input box for installation. pls let me know the package name. Regards

You'd want to be looking for a PECL installer, not a PEAR installer (though the two are related).

If there's somewhere in your cPanel that handles PECL installation, the package name would be "Fileinfo".

In general, you won't be able to add extensions if you're on a fairly standard shared host.

So, I've run into this error as well, however when I install fileinfo via PECL, the warning message still appears on the installation screen.

You often need to restart Apache for changes to your PHP configuration, including extensions, to take effect.

Try making sure that the Fileinfo extension shows up in a test <?php phpinfo(); ?> script.

Thanks John - it turned out my problem was due to a fat-fingered typo in php.ini...