Error Message: Images not sized properly

Can anyone point me in the right direction to correct a sizing error message I receive when I try to add image files to item records? I cannot get my images to post within my Omeka site.

My images are sized at 1050 x 750 ppi and they are jpegs. When I try to add an image file to an item record, the message I receive indicates that images are not sized properly.

I've adjusted the maximum pixel dimensions several times in "Settings" up to 2048 ppi. Is there a way to resort back to the default sizes or do I need to resize my images?

Initially, I was able to download one of my images, before I began changing the image settings several days ago. (even though, as noted in a previous post, the the image was displayed as a square)

Thanks if you have any suggestions


The derivative image sizes do not apply retroactively; They're only applied to new image files. Any images you've uploaded previously cannot be resized unless you re-upload the image file to the item you associated it with.

What is the sizing error message you receive? And, can you provide a link to your Omeka site, specifically a link to an item that has image files?

Hi Jeremy, Thanks for your message. This is a class project at the UofArizona and the sites are not public so I cannot provide you with a URL.

The message "Image derivatives are not sized properly" comes up after I enter an item, then go to files and try to add an image file by browsing to my folder of images.

In settings, I changed thumbnail to 640 x 480, I left the square thumbnail at 200 x 200, and I changed the full sized constraint to 1024 x 768.

This is my latest size adjustment in settings I tried many other sizes and nothing seems to allow my images to populate. I made a screen shot, but don't think I can attach it here.

Hi dnilsen, What's the exact text that you're writing in the textfields for the derivative image constraints? They only take the value of the longest side, meaning you'd enter 640 for thumbnails, and 1024 for the full sized constraint.

Does that fix the problem?

Thanks Dave, I believe I tried entering one dimension in the full size image field, but I'll try again as I may not have done it consistently in the three fields that can be altered. I appreciate your effort and will let you know.

Dave, your post was the solution. I was using both dimensions in the image size configurations. When I entered only the longest dimensions the images loaded.

Thanks very much for your help.