Error 500 on localhost installation


I read about Omeka in the latest Scout bulletin and thought I'd give it a go on my Macbook, running it on localhost with XAMPP:

PHP 5.3.0
MySQL 5.1.37

I downloaded v1.1 and unzipped the archive, put it into local web space, and tried to access it at http://localhost/~fredriley/test/omeka after cranking up XAMPP. I got an error 500. Another curiousity is that when accessing the parent directory, the /omeka directory didn't list even though it has the same permissions and owners as the other dirs:

drwxr-xr-x 7 fredrile fredrile 238 Feb 5 18:27 .
drwxr-xr-x 22 fredrile fredrile 748 Jan 5 18:29 ..
-rw-r--r-- 1 fredrile fredrile 6148 Feb 5 18:24 .DS_Store
drwxr-xr-x 37 fredrile fredrile 1258 Jan 15 20:35 PHP
drwxr-xr-x 25 fredrile fredrile 850 Nov 6 13:17 dotproject
drwxr-xr-x 2 fredrile fredrile 68 Oct 28 20:48 images
drwxr-xr-x 17 fredrile fredrile 578 Oct 15 14:42 omeka

I had a look at the Apache error log in /var/log/httpd/ but there were no entries for today.

I've edited the db.ini file as follows:

host = "localhost"
username = "root"
password = ""
name = "omeka"
prefix = "omeka_"
;port = ""

That is the correct user and pass for the local mySQL installation.

I did have a look in the docs and forum for "error 500" and hit:

but neither thread was directly relevant.

Does anyone have any suggestions? This smells of a .htaccess error but in the latter thread above users are advised against .htaccess editing.

Here is a thread on XAMPP that you might want to read through.

We don't support XAMPP specifically, but if anyone else has ideas please jump in.

Thanks for the reply and pointer, Sheila. I didn't think to look for XAMPP in the forums. I don't think the thread you quote is relevant as the original poster's problem is a Zend error. In one of the replies wanderingwill wrote that he:

"was able to successfully install Omeka on XAMPP for the Mac under the /Applications/XAMPP/htdocs directory, although XAMPP had .htaccess problems for mod_rewrite and setting php settings under my user's Sites directory. "

He didn't specify what the problems were, though. I don't think that this is a XAMPP issue in particular - XAMPP is purely a handy bundle with Apache, mySQL and PHP, so any errors it throws will be related to one of these three. I still think that there's a smell of a .htaccess problem with the error 500, but my eyes glazed over when I looked at the mod_rewrites in the code as I'm not much good at regexes. Maybe I should try to comment out lines and see what happens?

I'll give it a go on a Windoze machine with XAMPP to see if the problem recurs. I do have an old tin box running Linux upstairs but I've not cranked that up in a while.


Have you tried using MAMP?