Edit file metadata

I am trying to edit the file metadata for an image (specifically, to add a watermark) but when I Save Changes I get the following error:
Cannot find an element with an ID of '86'!

What version of Omeka are you using?

I just edited the file metadata for an image on Omeka 1.1, specifically the watermark data, and it seemed to work.

I'm running Omeka 1.1. I'm trying to add a title in the file metadata, and I get the same error message as mjessup:

Cannot find an element with an ID of '88'!

delevinson and mjessup,

Have you ever manually edited the database?

One of our test sites had someone manually remove an element from the database and re-add it, and had a similar error.

In my case, it looks like a bug in the Extended Dublin Core plug-in. I uninstalled that and now I see no error message.

delevinson, you are correct; it is a bug in the Dublin Core Extended plugin. We will fix the bug and release the updated plugin with the upcoming 1.2 release of Omeka.

Hey guys!

We have been using omeka and now we had to edit file metadata but got the same error: "cannot find...ID '88' or '86' or '129'" Using Omeka 1.1.

I uninstalled DC Extender from test instance of omeka and it worked, no error. So that IS the cause of it. But it also took away the data (as expected). Ofcourse i can't do that for production. I looked at dublin extender plugin and i see no updates in change/release log for 1.2. Was this fixed in 1.2???

Would it possible to find out what the fix was?