Dublin Core Extension Error

I installed Dublin Core Extension plug in on my Omeka 2.0.1 install, but it didn't work. So i am trying to uninstall it now so i can re install and I am getting this error

Fatal error: Call to a member function delete() on a non-object in /var/www/plugins/DublinCoreExtended/DublinCoreExtendedPlugin.php on line 72

I manually deleted the plug in and re unzipped it and reactivated it but it still wont un install.

Any ideas?

What went wrong when you installed the plugin?

It sounds like you don't actually have the extra Dublin Core elements that this plugin adds. When it tries to remove them during the uninstall, it chokes because they don't exist.

The new Dublin Core elements do not show up when I am adding a new item.

How would I get those elements? I thought I installed this plug in before on a 2.0 test and it worked fine. Having Omeka 2.0.1 shouldn't be the issue should it?

None of them are there (you only have the original 15 elements under Dublin Core)?

That would seem to indicate that the plugin never really got installed correctly in the first place. If you think that's the case, you can manually remove the DublinCoreExtended entry from your "plugins" table in the database, and Omeka will act as if it's not installed.

So go to like var/www/plugins and delete it? I did that several times and re unzipped the package.

No, it's not the plugin's files you want to get rid of, it's the information about the plugin Omeka saved in its database (MySQL).

You might have a graphical MySQL administration tool like PHPMyAdmin provided by your host that lets you make changes relatively easily.

I have this on a VM on my local at the moment.

If I drop my MySQL db and remake it should that fix it?

Dropping the DB worked.

Thanks for you help! Awesome as always :)