Dropbox - Tried to delete missing file

My other topic with this same text seems to have gotten closed somehow so I'll post it again. Has anyone seen this before?

I'm having a problem with Dropbox. I can successfully upload a jpg file of size 756899 using browsing to find the file on my computer; however, when I put the file in my Dropbox/files folder (protections changed to 777 on the directory), I'm unable to upload the file using Dropbox. I get the following in my errors.log file:

2013-06-05T12:05:36-04:00 WARN (4): Omeka_Storage_Adapter_Filesystem: Tried to delete missing file 'files/34a55ab5b67781bbba2e8f9bbba91043.jpg'.
2013-06-05T12:05:36-04:00 ERR (3): exception 'Omeka_File_Derivative_Exception' with message 'Something went wrong with image creation. Please notify an administrator.' in /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/File/Derivative/Image.php:189
Stack trace:
#0 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/File/Derivative/Image.php(113): Omeka_File_Derivative_Image::createImage('/tmp/34a55ab5b6...', '800', 'fullsize')
#1 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/File/Derivative/Image.php(222): Omeka_File_Derivative_Image::createDerivativeImages('/tmp/34a55ab5b6...')
#2 /prodat/omeka/omeka-1.5.3/application/models/File.php(248): Omeka_File_Derivative_Image::createAll('/tmp/34a55ab5b6...', 'image/jpeg')
#3 /prodat/omeka/omeka-1.5.3/application/models/File/ProcessUploadJob.php(24): File->createDerivatives()
#4 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Job/Dispatcher/Adapter/Synchronous.php(25): File_ProcessUploadJob->perform()
#5 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Job/Dispatcher/Default.php(95): Omeka_Job_Dispatcher_Adapter_Synchronous->send('{"className":"F...', Array)
#6 /prodat/omeka/omeka-1.5.3/application/models/File.php(70): Omeka_Job_Dispatcher_Default->send('File_ProcessUpl...', Array)
#7 [internal function]: File->afterInsert()
#8 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Record.php(282): call_user_func_array(Array, Array)
#9 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Record.php(561): Omeka_Record->runCallbacks('afterInsert')
#10 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Record.php(581): Omeka_Record->save()
#11 /prodat/omeka/omeka-1.5.3/application/models/Item.php(303): Omeka_Record->forceSave()
#12 /prodat/omeka/omeka-1.5.3/application/models/ItemBuilder.php(213): Item->saveFiles()
#13 /prodat/omeka/omeka-1.5.3/application/libraries/globals.php(505): ItemBuilder->addFiles('Filesystem', Array, Array)
#14 /prodat/omeka/omeka-1.5.3/plugins/Dropbox/plugin.php(82): insert_files_for_item(Object(Item), 'Filesystem', Array)
#15 [internal function]: dropbox_save_files(Object(Item), Object(ArrayObject))
#16 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Plugin/Broker.php(156): call_user_func_array('dropbox_save_fi...', Array)
#17 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Plugin/Broker.php(182): Omeka_Plugin_Broker->callHook('before_save_for...', Array)
#18 [internal function]: Omeka_Plugin_Broker->__call('before_save_for...', Array)
#19 [internal function]: Omeka_Plugin_Broker->before_save_form_item(Object(Item), Object(ArrayObject))
#20 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Record.php(304): call_user_func_array(Array, Array)
#21 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Record.php(803): Omeka_Record->runCallbacks('beforeSaveForm', Object(ArrayObject))
#22 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Controller/Action.php(482): Omeka_Record->saveForm(Array)
#23 /prodat/omeka/omeka-1.5.3/application/controllers/ItemsController.php(99): Omeka_Controller_Action->editAction()
#24 /prodat/omeka/omeka-1.5.3/application/libraries/Zend/Controller/Action.php(516): ItemsController->editAction()
#25 /prodat/omeka/omeka-1.5.3/application/libraries/Zend/Controller/Dispatcher/Standard.php(295): Zend_Controller_Action->dispatch('editAction')
#26 /prodat/omeka/omeka-1.5.3/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#27 /prodat/omeka/omeka-1.5.3/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#28 /prodat/omeka/omeka-1.5.3/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#29 /prodat/omeka/omeka-1.5.3/application/libraries/Omeka/Core.php(165): Zend_Application->run()
#30 /prodat/omeka/omeka-1.5.3/admin/index.php(44): Omeka_Core->run()
#31 {main}
2013-06-05T12:06:42-04:00 WARN (4): Omeka_Storage_Adapter_Filesystem: Tried to delete missing file 'files/906bfbb554565555929676b22b529326.jpg'.
2013-06-05T12:11:01-04:00 WARN (4): Omeka_Storage_Adapter_Filesystem: Tried to delete missing file 'files/7f58478f2851758d9aec2897ba7bbfe0.jpg'.
2013-06-05T12:16:50-04:00 WARN (4): Omeka_Storage_Adapter_Filesystem: Tried to delete missing file 'files/36ff57f737ef3bb7c702a7093dcbd9a1.jpg'.

Details of my system are:

Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
Role: super

Omeka: 1.5.3
PHP: 5.3.3 (apache2handler)
OS: Linux 2.6.32-358.6.1.el6.x86_64 x86_64
MySQL Server: 5.0.95
MySQL Client: 5.1.69
Apache: Apache/2.2.15 (Red Hat)

PHP Extensions
Regular: apache2handler, apc, bz2, calendar, Core, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gettext, gmp, hash, iconv, json, ldap, libxml, mbstring, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, Reflection, session, shmop, SimpleXML, sockets, SPL, sqlite3, standard, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, zip, zlib

Coins: 0.4
CollectionTree: 1.1.1
Commenting: 1.0
CsvImport: 1.3.4
DocsViewer: 1.0
Dropbox: 0.6
EadImporter: 1.0
ExhibitBuilder: 1.2.1
Geolocation: 1.2
ImageAnnotation: 1.0
ImageResize: 1.0
ItemRelations: 1.1
LcSuggest: 1.0
MyOmeka: 1.0.1
Neatline: 1.1.3
NeatlineFeatures: 1.1.0
NeatlineTime: 1.1.3
Scripto: 1.3.1
SimplePages: 1.3.1
SimpleVocab: 1.3
Tweetster: 1.0

Minimalist Omeka Theme:1.2
Rhythm: 1.3
Scribe: 1 (current)
Seasons: 1.3
Thanks, Roy: 1.5

I have more info on this that I'm hoping means something to someone. I upload multiple files to the Dropbox/files folder and I can successfully load all the items into omeka until I get to the last one. If the last file in the Dropbox/files directory is included in the item add, I'll get the error above. As long as a file remains in the files direcotry, the item add works as it should. If the item add includes the last file, I'll get the error mentioned, the item will be created without the given title or image or further metadata and the file will be deleted from the files directory. So afterwards I'll have an item called [Untitled] and the file will be gone from the files directory.

Further testing shows that this problem isn't a problem with the last file in the directory. It seems to be a problem with the file size that Dropbox can upload. I can upload lots of small jpgs with Dropbox and empty the files directory, but if I try to upload the file that is larger (size 756899), I get the error mentioned. I can upload this file by browsing to find the file and that works fine. I can't upload it with Dropbox. Small files are fine. Where do I change this configuration setting? Please help.

That's in bytes?

That's not very big, not even a megabyte. Is it possible the file might just be corrupt or badly-formatted instead? The error message above is an ImageMagick error, and it doesn't make much sense for that to work differently between the Dropbox and the normal upload.

Have you tried deleting and re-uploading to the Dropbox files directory? Maybe something went wrong with the first file transfer.

Thanks for the help. Yes, it does appear that the files were corrupt. I transferred them off the server and put them on my desktop where my VM is running and the files were not complete.