Dreamhost Installation Trouble (htaaccess file?)

I am getting started w/ Omeka and want to build a site on a dreamhost server. I've followed the steps, but when I visit the site, I receive the following messages that I cannot make head or tail of:

Warning: require_once(Zend/Loader/Autoloader.php) [function.require-once]: failed to open stream: No such file or directory in /home/rmdavis1/visualizing-evolution.c19audiences.com/paths.php on line 189

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Loader/Autoloader.php' (include_path='/home/rmdavis1/visualizing-evolution.c19audiences.com/application/libraries:/home/rmdavis1/visualizing-evolution.c19audiences.com/application/models:.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/rmdavis1/visualizing-evolution.c19audiences.com/paths.php on line 189

Dreamhost says it's the htaaccess file and this post (http://omeka.org/forums/topic/error-on-installation#post-67526) has some similarities, but does anyone have any insight on how to go about fixing the error?

If you have ideas that would be awesome, if you can explain them slowly and loudly, that's be awesomer!


The first thing to check is whether the .htaccess file was actually uploaded. A lot of FTP applications will skip over files that begin with . unless you turn on "show hidden files" or "show dot files" or something like that to make sure you catch it.

Hi, thanks for the reply. The .htaccess file IS there according to my FTP. Could there be something in the file that does not interface with DH?

I wouldn't think so, but just to double check could you post up exactly what's in the .htaccess file?

Sure. Here's the text of the file:

# Omeka .htaccess: Apache configuration file
# This file is required for Omeka to function correctly.

# --------------- #
# Error Reporting #
# --------------- #

# Uncomment the SetEnv line below to turn on detailed on-screen error
# reporting.
# Note: This should only be enabled for development or debugging. Keep this
# line commented for production sites.
# SetEnv APPLICATION_ENV development

# ------------- #
# Rewrite Rules #
# ------------- #

RewriteEngine on

# If you know mod_rewrite is enabled, but you are still getting mod_rewrite
# errors, uncomment the line below and replace "/" with your base directory.
# RewriteBase /

# Allow direct access to files (except PHP files)
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule !\.php$ - [C]
RewriteRule .* - [L]

RewriteRule ^install/.*$ install/install.php [L]
RewriteRule ^admin/.*$ admin/index.php [L]
RewriteRule .* index.php

# -------------- #
# Access Control #
# -------------- #

# Block access to all .ini files.
<FilesMatch "\.ini$">
Order Allow,Deny
Deny from all

# --------#
# Caching #
# --------#

# Uncomment the lines below in order to enable caching of some files
# (after a finished site has gone live)
# <IfModule mod_expires.c>
# <FilesMatch "\.(js|ico|gif|jpg|png|css)$">
# ExpiresActive on
# ExpiresDefault "access plus 10 day"
# </FilesMatch>
# </IfModule>

# ------------ #
# PHP Settings #
# ------------ #

<IfModule mod_php5.c>
php_flag register_globals off
php_flag magic_quotes_gpc off

Interesting. The original error message looks like something from Omeka 1.5, but the .htaccess looks like Omeka 2.0. Did you do a conversion or update?

If it is a brand new project, and you don't need plugins that are not yet available for 2.0, it might work to delete everything and make sure you are starting from a clean Omeka 2.0 codebase

Interesting. I was trying to install this to a Dreamhost Omeka installation. Could it be possible that they are working with a previous version? I downloaded the 2.0.3 folder and have been working with that.

Regardless, will try it afresh.

The require_once errors you're seeing probably don't have anything to do with .htaccess.

Definitely possible. DreamHost has the handy one-click install, but last I heard hasn't updated it to the current version of Omeka, 2.0.3.

Yes, that was it. I just assumed DH would be up-to-date, but they are still on 1.5.3. I deleted 2.0.3 from the server and uploaded 1.5.3, but now I get the following error:

mod_rewrite is not enabled
Apache's mod_rewrite extension must be enabled for Omeka to work properly. Please enable mod_rewrite and try again.

Do you know if this is something I can do, or should I start over from complete scratch by reinstalling omeka on their server?

I see two things at work.

First, if it's a new install, definitely much better to delete all and do a "manual" install of Omeka 2.0.3

Hopefully that will go smoothly. But if mod_rewrite problems continue, it'll be easier to know we're looking at 2.0.3

So, yes. Starting from scratch on 2.0.3 will guide the process more smoothly, I hope.