Difficulty upgrading Omeka software


When I first tried to upload the latest software, I encountered many difficulties. Fortunately, I have backup of all of my previous files. Consequently, I decided to change it back to how it once was--back to Omeka 1.1 version so that I could start over with the upgrade. Unfortunately, when I did that, I received the following error message while trying to login to my Omeka/admin/users/login page:

Warning: require_once(Omeka.php) [function.require-once]: failed to open stream: No such file or directory in /home/lubutoco/public_html/paths.php on line 167

Fatal error: require_once() [function.require]: Failed opening required 'Omeka.php' (include_path='/home/lubutoco/public_html/application/libraries:/home/lubutoco/public_html/application/models:.:/usr/local/php52/pear') in /home/lubutoco/public_html/paths.php on line 167

What is the meaning of this and how can I fix it? Do you have a copy of this Omeka.php page? How can I download it? I do not seem to have it in any of my file folders. How should I proceed?

It sounds like you either got a bad zip of Omeka (unlikely), or that you didn't quite get all the files uploaded or all put in the right places.

Did you follow the upgrade instructions? The easiest way to make sure you get all the files where they should be is to follow those basic instructions: don't try to replace the files in your installation piecemeal, just install the new files "clean", then copy your config files, "archive" dir, and plugins/themes over.

I'm sorry, I didn't realize immediately that your question is about going back. I do think you'll be better off moving forward with the upgrade, though.

For restoring your old installation, the same basic advice applies. You want to make sure that you're using all files from the same Omeka version (with the exception of things like db.ini and the archive dir obviously). You may have accidentally deleted some files from your old install, or let a file from a newer Omeka version slip in.

If you need it, you can still get the Omeka 1.1 zip from our version history page.

Okay--I have successfully followed all of the upgrading steps. However, now when I try to upgrade the "database", it gives me the following error message:

Omeka is now upgrading itself. Please refresh your screen once this page finishes loading.

Omeka encountered an error when upgrading your installation:

Error in Migration #1

Message: Migration file does not exist for #1!

What does this mean and how do I fix it? I want to move on to upgrading it to the latest version. Thank you!

Hi--I am trying to upgrade to the 1.5.3 version as soon as possible. Can I just skip the step of updating the database since it doesn't seem to be cooperating and move on to uploading the latest software into the cPanel siteground? I followed all of the instructions before. I have no idea why it isn't working properly.

I uploaded the 1.2.1 software into the FTP server siteground. I unzipped the file after moving all of the old omeka software files out and put all of the new files in the public_html section. I kept the old archives folder and the old db.ini document from the prior omeka folders and put them into the public_html site. I even "backed-up" the entire siteground cPanel which included all of the old omeka folders, images, and archives. I also went through MyPhP administrator on the cPanel and backed up the old database. Even after all of that, things still aren't working properly. What is happening?

When I backed up the database, I received the following file: lubutoco_collections.sql and I saved it to the public_html folder. That way, I can always have access to it from any computer if need be. Is there anything else I need to do? I followed all of the steps and upgraded the 1.2.1 omeka software a second time. Please help me! I need to get this project going and I can't do it without the upgrade.

The "upgrade the database" step is important, you can't really skip it.

The error about "migration #1" is strange: if you were previously using Omeka 1.1, you should be starting from migration #42. It's possible there's been some problem, and the piece of data Omeka needs to tell what version your database is was somehow lost.

The current migration number is stored in your DB's "options" table, and it's called "migration." It should have a value of "42" if you were previously running Omeka 1.1. Manually changing that value may allow you to successfully perform the upgrade step.

Hi John,

Thanks for replying so quickly. I am having some tremendous difficulty here. I went through all of the old public_html files to be sure I didn't leave anything out when I transferred the new files from the 1.2.1 version into the public_html file. I also went into siteground.com and looked at the cpanel to figure out how I could find the database so that I could find the options table and search for migration and change the value to 42. I could not find the options table. I am assuming MySQL is our database. So how do I find the options table within the cPanel of site ground? Maybe I have to upgrade to the newer sql version. How can I tell what version it is? I suppose I'll have to get a new password first since it is asking for one.


Can you share that migration table within the "options" tables with me somehow? I didn't see it listed in the database. What can I do?

I accessed the database files through PhPMyAdmin in siteground's cpanel.

So, did you find the options table? It would probably be called "omeka_options" by default.

I did find the "Omeka_options" table, but I did not find migration within the list. "Migration" didn't exisit. I created the migration table myself. I simply gave it the name migration with a value of 42 and an ID of 42. Nothing happened after I saved it. I still got the same error message. The message read:

Omeka encountered an error when upgrading your installation:

Error in Migration #1

Message: Migration file does not exist for #1!

What can I do?

Hi John,

Fortunately I was able to fix the problem above by installing the old omeka.sql database file into the PHPMyAdmin. Then it worked. I was able to upgrade the software and move on to the next installation. Interestingly enough, I was only able to upgrade to the Omeka 1.3.2 software. For some strange reason, I am unable to upgrade to the 1.5.3 software. When I attempt to do so, I get the following message: "Public site is unavailable until the upgrade completes."

When this happened, I decided to just stick to the Omeka 1.3.2 software instead, since that is the highest I can seem to go. What is going on? How come I can't upgrade to the latest software? The database has been updated, 1.2.1 worked perfectly. What is the issue?

When you tried to go from 1.3.2 to 1.5.3, did you just unzip the new files on top of the old ones?

You could be having one of two problems: The first is easy: you need to go to the admin site URL to do an upgrade.

If you're on the admin side when you see that error, what you're describing sounds like a problem with ".htaccess" files. Older versions of Omeka had an ".htaccess" file in the top directory, and another in the "admin/" directory. Current versions of Omeka don't have the one in the "admin/" directory anymore, and they won't work with it there.

Yes I did that: I did go to the admin site URL to do the upgrade and I still got the following message: "Public site is unavailable until the upgrade completes."

In addition, I did a search for the .htaccess files...I deleted every single file in my public_html files except for the db.ini and archives files like instructed and dumped the 1.5.3 files in--so...there shouldn't have been any unnecessary .htaccess files in the admin directory. Now what do I do?

Can you see the ".htaccess" file in the top Omeka directory?

They can be easy to miss, because the dot at the beginning of the name marks them as hidden files. Your FTP or other client may make you toggle some setting to show hidden files.

If you can see the top-level .htaccess file, then the problem probably lies elsewhere. If you can't see it, then you might need to check your settings to make sure you can see hidden files.

Thanks John!!!

I was finally able to update the Omeka version by following your instructions. I simply toggled a setting to show hidden files and I was able to delete the extra .htaccess files from the admin files and other folders. Thank you so much for all of your help. Now I have just one other question---do you happen to know how to embed a file like an etoy in omeka? http://booki.flossmanuals.net/etoys-reference-manual/_full/

It is .pr file if that helps. It has moving images and pictures. Do you have any suggestions or recommendations? Thank you!

I'm not sure how that type of file works, and if or how you can embed it in a webpage.

If they can be embedded (and possibly displayed by a browser plugin), you'd likely need at least a minimal Omeka plugin to create the correct markup.