Description field not Available

We recently upgraded from 1.x to 2.3 and installed a new CSV importer, 2.0. It accepts our standard csv files but does not include "description" among the fields shown in the dropdown choices for each column. We need that field. What to do?

That's a very odd one. The dropdown should be be populated from the entire set of fields that exist in Omeka. Is the description field appearing when you edit an item?

Yes. The description field shows for the items on the rest of the site. We are using the default Dublin Core element set and have not changed that. We did add a couple of fields outside of Dublin Core.

Even more mysterious. Are there any other fields that you notice are missing? And, I'm guessing you added the other fields as part of Item Type all of that intact?

All the standard fields are available except Description. Our previous add-on field, people, is available and two other Item Type Fields, Original Format and Physical Dimensions are available. I don't remember that we added those. We certainly did not use them. A screen shot is available here:

In further experiments I pre-flagged the columns hoping to pick up the description field. No luck. Then I eliminated the description column in a test and it throws an error on import: Zend_Db_Statement_Mysqli_Exception
Mysqli prepare error: Unknown column 'original_filename' in 'field list'

#0 /home/pateam/public_html/application/libraries/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('INSERT INTO `om...')

Maybe the table CSV Import is abstracting is corrupted and has "Original Format" but not "Description". If so there may be a way to examine that table and fix it.

Hello PatrickMJ are you out there? I have been hoping you would suggest a table to look at to find the errant fields but you have stopped responding to this problem. It has not gone away and we have hundreds of items to upload.

I haven't been able to reproduce this or come up with possible reasons for this to happen. The table that the dropdown gets data from is called elements. There should be a row with something with name column "Description", and with a column element_set_id for the "Dublin Core" element set. Usually the element_set_id is 1, but you can double-check that by looking at the element_sets table and making sure that the element set with id 1 is Dublin Core.


Knowing the table name allowed me to change the record that was showing as Original Format to Description with an element_set_id of 1 and an order of 17 and change the record for Description to "Original Description" That made the import work. I assume that there was something corrupt in the "Original Description" record. Thanks for the help.

I really don't understand this. I would not want to change the Dublin Core Description to something else. Also, the SQL error was on original_filename not original_format. I don't know why not including it in the import would cause that error. I would need more detail to explain what happened. Glad it worked for you.


Yes you really didn't understand it. I'll try to be more clear. Yes the error read original_filename but at first the CSV import was picking up a record that had "Original_Format" in it from the elements table and missing a record that had "Description" in it. I guessed that there was something corrupted in that table and switched the information in those two records except that I changed the element_set_id for the new Original_Format record (the old Description record) to 4 from 1. So I didn't remove the Description record, I just moved it. I know it was a wonky solution but it worked.