Database seems to disappear intermittently

I have Omeka installed on a Bluehost site and have been getting some strange behavior.

At the moment I get the Omeka Database error: 'Access denied for user' every time I try to navigate to the Omeka site. The database set up for Omeka seems to still be present on Bluehost, but is listed as taking up 0 MBs. Interestingly, most of the images that were uploaded through Omeka seem to still be in the omeka/files directory.

This is actually the second time this issue has occurred. The first time everything worked fine for a week or so, and then this error started, making it impossible to access the Omeka admin panel.

I then deleted the Omeka database and created a new one, and everything worked fine for about another week before failing.

I'm wondering if other people have had issues like this, or if someone at least has an idea of where the problem might be originating (plugins installed are SimplePages, ExhibitBuilder, Coins, and Neatline).

Is there some way to go about accessing the Omeka admin panel while this error is occurring? Secondly, if I do end up deleting the database and starting again, is there anything I should do to clean up the omeka directories to prepare for starting over?

Have you asked Bluehost's support about this?

This doesn't sound like anything that a plugin would have caused.