CSVImport File Download Problem

I'm trying to test CsvImport, I keep getting an error when I import:

Import Error: Invalid File Download

URL is not readable or does not exist: http://<omeka_install>/plugins/Dropbox/files/nar.00883.001_large.jpg

However, if I grab the URL it gives me, and paste it into a browser, I'm able to view the image just fine. Additionally, if I import the file directly through Dropbox, everything works fine ("Successfully uploaded", created an item with the file, etc)

Using Omeka 1.1, Dropbox 0.4, CsvImport 1.2

Ha just realized those links didn't come through quite right. I pulled the actual server out of them on general principle.

Maybe this will work?



Here's the entire test csv file:


Not sure if that will come through like I expect, but basically the csv file has one field 'filepath' and the only record is a URL (which, if you paste it into a browser it works just fine). Note that this was thinned down from a more complete csv file, the same problem was occurring when there were more fields and multiple records.

The omeka_install directory (again, not the actual name), has 775 permissions, with apache:omeka_install ownership, and the apache user is part of the omeka_install group (not that that should be necessary but oh well)

I'm not able to access the url you just posted. Have you tried using a url that is publicly accessible?

Figured it out with the help of clioweb and wanderingwill at #omeka on chat.freenode.net. Thanks again!

The issue is that allow_url_fopen on our server was set to Off, *but* since CsvImport uses the cli-php (Command Line Interface (?) PHP), that is where you need to change your setting. On our server, in /etc/php, there are two directories: apache2-php5 and cli-php5. I needed to put the following in /etc/php/cli-php5/php.ini:

allow_url_fopen = On

There should be a line that says allow_url_fopen = Off already in the file, either remove it or replace it.

I believe this would have worked had we used a system path e.g. '/var/www/localhost/htdocs/plugins/Dropbox/files/nar.00883.001_large.jpg' also, if you don't want to set open up file access and don't need URL access.