CsvImport and background process problem?

Hi, I have the Omeka and the CsvImport plugin installed on several machines and it's working fine. I've just put it on a new server (which I have control over) but I am having a problem (and am looking for suggestions for next steps)...

So, when I run the CsvImport on the test.csv file that comes with it nothing happens. I've looked in /var/log/httpd/errors_log and application/logs/errors.log but I don't see any errors (and I have them turned on in the config and .htaccess). I'm assuming that it is just not able to run the PHP background process so I've set the location of my php cli in application/config/config.ini (/usr/bin/php), but that still doesn't work (and still no log messages).

To test the background PHP path, I've changed the location of background.php.path in the config.ini to something that doesn't exist (/there/is/no/php), thinking I'll at least see the error of it not being able to find the PHP cli. Still no error message... Any ideas? Where in the code could I set an echo to see what's being called as the external php or any other ideas for steps I could take to figure out why it's not working on this particular machine?


What versions of CsvImport and Omeka are you using?

The latest CsvImport doesn't use a background process at all by default.

Omeka stable 1.5

latest CsvImport (checked out from github)...

ah, okay, so it's not background process

Just to close out this post, the dev team was able to help me in the omeka IRC channel. It seems in controllers/IndexController.php there is a call $this->session->setExpirationHops(2) that tells how long to keep session data around. My problem was fixed by increasing the number of allowed hops. So, what was happening was that the plugin wasn't parsing the CSV file because the session data was lost before it could be processed... keeping the data around a little longer fixed it. Thanks omeka dev team!