CsvImport 1.3 hangs

I've got a fresh intstallation of 1.3, and the only plug-in I have running is CsvImport for 1.3. I managed to do this all on 1.2 without any problems. But now, when I click on the tab to actually use CsvImport, the web browser hangs, and nothing happens. Clicking cancel, or any other link on the page does nothing at this point. If I try to access my main site by going to another tab, nothing happens. The only way to get the site/browser responding is to completely close all tabs and windows for the browser, and I can get back in and all is well unless I click on the CsvImport tab again in the admin panel. Please help.

Further information: I have installed Omeka 1.3 with CSVImport 1.3 on a test server and it works just fine. The problem site is on Lunarpages. They report:

I can provide you details on what we're seeing on the server-side however I'm not sure how useful they will be to you. When the URL http://www.kopn.us/r2r/admin/csv-import/ is accessed two PHP processes are spawned as we can see here:

kopn03 4313 5.0 0.4 32504 17392 ? S 04:22 0:00 /usr/bin/php /home/kopn03/public_html/kopn-us/r2r/admin/index.php
kopn03 4403 4.0 0.3 31464 16288 ? S 04:22 0:00 /usr/bin/php -v

The second process is a background PHP process spawned by the index.php script. If we do an strace on the background PHP process this is what we get:

Process 4403 attached - interrupt to quit
flock(5, LOCK_EX

Unfortunately the script simply hangs infinitely and there's no good way for us to trace the entire life of the process until it hangs as it executes too quickly. You may want to check support channels for the plugin to see if there's anything relating to this issue. I haven't seen any evidence that it's a server-side issue from the data we have, but if the issue cannot be resolved by other means we could attempt transferring you to a different server to see if it functions better there. Please let us know if you have any questions.

I have also tried adding in the /usr/bin/php into the config.ini file, this did not fix things. I have tried turning on logging as suggested elsewhere, and this did not work, even making the log folder fully open.

I would not be so desperate to get this fixed except I have been fighting this for two weeks and I have over 1000 entries in a CSV file to import. Any suggestions would be most appricated.

That's some interesting information.

The php -v process that your host mentioned does indeed get run when you go to the CsvImport page, but all it's supposed to do is return the version of the PHP-CLI binary, so we can check to make sure it's recent enough.

Can you SSH to your server and run php -v? It should just simply print a few lines with version numbers and copyright notices.

The server with the problem indicates that it is running PHP 5.2.14. I get this from the C-Panel interface, I do not have shell access. The site is hosted on Lunarpages, if this makes any difference.