CSV Pugin: Display Bug


I use the CSV plugin all the time for Images and Documents and it works great. However, today I am trying to use it with movie and audio files (in separate spreadsheets/processes) and I am having an odd issue. The checkboxes on the right of the column mapping interface are not visible and it looks like it's getting cut off.

Just noticed that if I use Firebug to turn off "overflow:hidden" on the form #csvinput then I can see them, so it is definitely a display/CSS issue.

I'm not sure why this would only happen for movie and sound files, but perhaps I just have an extra long URL for the first file location in the CSV by coincidence. (seems normal though, looks like: http://csudigitalhumanities.org/exhibits/plugins/Dropbox/files/littlewhitehouse.mp3).

I'm using Chrome for Windows7, Omeka 1.1

Thanks ebellempire.

I'll restyle the overflow for this plugin, so that the content is visible, but I think this issue applies more generally to other admin pages as well. So we will want to look into this.

I'm having the same issue. I have some long entries causing the overflow. So, if this is a CSS issue, what file do I need to fix, exactly? What's the workaround? I can't find the form ebellempire has described, to be able to turn off "overflow:hidden".

Also, regarding my long entries, is there any kind of limitation on character length for a field, etc.?



I recently made this CSS fix on the CsvImport trunk:

With this fix, the user should be able to see checkboxes on the mappings page for really long field values (although it may not look pretty).

In terms of character length limitations for importing,
I believe the element texts, which ultimately store field data, use MEDIUMTEXT data type, which can hold a "string with a maximum length of 16777215 characters" http://www.htmlite.com/mysql003.php