CSV Import--Skips all items

Hi there:

I've used CSV Import successfully in the past, but nothing I can do seems to make this one work. (We're using Omeka 1.5.3 and CSV Import 1.3.4)

I believe the CSV file is correctly formatted....any ideas what would cause it to skip all of them?

A couple pieces of info will help track this down.

When you have successfully imported before, was it with the same version of Omeka and of CSV Import?

Also, do the sample CSV file that's in the plugin's csv_files directory import okay?

That will help us determine whether the problem is in the file, a server setting, or a bug in the plugin itself.

Thanks so much for responding!

Yes, I was using the same version of Omeka and CSV Import. The test.csv works fine.

I'm going to assume there's something up with the file? I've checked the links and they all seem in order. I am not sure what else it could be?

Depending on how the CSV was created, there could be quirks with character encoding or other things. Does it all look right when you open it in a plain text editor like Notepad? If so, sometimes just saving it from the plain text editor removes encoding issues

It looks totally fine when I open in in Notepad. I tried saving and reuploading. It's skipping all of the items, and occasionally 1 of the rows. (I'm not sure if the distinction is meaningful...)

Could you paste in the header row, and a couple representative rows from the CSV?

Thanks so much. Here's the csv I'm working with. In general, are there any things that always trip up the plugin to guard against? We're going to be migrating a lot of exhibits (and a lot of metadata...)

May-60,,A Report to the Citizens of Chapel Hill ,www2.lib.unc.edu/mss/exhibits/protests/images/catalog90.jpg,Copyright Chapel Hill News.
12-Jun-63,"Floyd McKissick Papers (#4930), Southern Historical Collection, Wilson Library, University of North Carolina at Chapel Hill.",Advertisement for the Colonial Drug Company ,www2.lib.unc.edu/mss/exhibits/protests/images/catalog78_1.jpg,Copyright Chapel Hill News.
26-Jul-64,"Floyd McKissick Papers (#4930), Southern Historical Collection, Wilson Library, University of North Carolina at Chapel Hill.",Letter from Lou Calhoun to Floyd McKissick ,www2.lib.unc.edu/mss/exhibits/protests/images/catalog78_5.jpg,
26-Jul-64,"From Allard K. Lowenstein Papers (#4340), Southern Historical Collection, Wilson Library, University of North Carolina at Chapel Hill.",Letter from Lou Calhoun to Floyd McKissick ,www2.lib.unc.edu/mss/exhibits/protests/images/catalog78_4.jpg,
29-Aug-64,"From Allard K. Lowenstein Papers (#4340), Southern Historical Collection, Wilson Library, University of North Carolina at Chapel Hill.","Postcard to James Farmer, National Director of CORE",www2.lib.unc.edu/mss/exhibits/protests/images/catalog78_2.jpg,
29-Aug-64,"From David Schenck Papers (#5288), Southern Historical Collection, Wilson Library, University of North Carolina at Chapel Hill.","Postcard to James Farmer, National Director of CORE",www2.lib.unc.edu/mss/exhibits/protests/images/catalog78_6.jpg,

Yep! As above, encoding is a very common trip-up to the plugin, but we've covered that. Another common reason for items to skip is a problem with the file upload. In this case, the plugin just needed the http:// before the URLs. When I added those, all 6 records here imported okay.

Wow. I was bracing myself for it to be something simple....
Thanks so much for your help!


I apologize in advance for posting this also on a thread about uploading audio. I'd appreciate someone's help so much with this problem:

I've been following the steps for the CSV import, but it's not working. Here's what I did:

I set up an Excel file with fields Title, Creator, Date, and URL, and put my file info there.

Then, I saved as CSV, and went to Omeka's CSV Importer to import.

For the Import into Omeka, I chose the CSV file, indicated the media type (Sound, for my three mp3 sound clips), mapped title to title, creator to creator, and a date to date.

Then, I left the URL field from the CSV unmapped in Omeka, checking the "File?" box instead. Then, I clicked Import and ... 0 files imported.

Can someone please help? Was the problem that the URLs I was using ended in .mpg (they started with http:// ...., which I included)? Should I not have included the field name "URL" on my Excel/CSV documents? Could the problem lie in the fact that the URLs contained %20s instead of spaces (though the URLs with these characters work to link to the webpages).

It's pretty frustrating, because I'll need to make a lot of use of CSV importing, of all types of formats, and I don't know what I'm doing wrong.

I really appreciate your help!

It could be something odd with how Excel saves the CSV, and/or something with the URLS. Could you post up the first few lines of the CSV you are using?

It might also be worth checking the settings to make sure that .mpg files are allowed.

Hello! Thank you for getting back to me! You've been a big help to me in the past.

Here's a fake version of what I'm trying to import (I can't use the actual, but this accurately reflects what I'm working with); are the %20 possibly the problem?

Out dummy text: Intro,”Schmo, Joe”,12/10/56,http://fakename.com/MM%20sound/Joe/Schmo_dummy%20of%20text_Intro.mp3
Out dummy text: Main Theme,”Schmo, Joe”,11/3/54,http://fakename.com/MM%20sound/Joe/Schmo_dummy%20of%20text_Main%20Theme.mp3
Out dummy text: Lost in the Woods,”Schmo, Joe”,6/6/56,http://fakename.com/MM%20sound/Joe/Schmo_dummy%20of%20text_Lost%20in%20the%20Woods.mpg

Thank you for taking a look at this -- And: When I click CSV import, do I actually map the URL field to any other field? Or do I only map the first three, and simply check the "File?" box?

Finally, can you elaborate on what settings may not be allowing .mpg files -- Omeka's? I'm not sure where to look to determine that.

Thank you so much!!

Hi again -- still desperately trying to make the CSV import work, this time, to import a batch of jpgs. I would have thought this wouldn't be difficult, but I can't get it to work. I'm using Omeka.net -- is that the problem?

I have no idea what I'm doing wrong. Again, I'm mapping title to title, creator to creator, and date to date. With the File column, I've checked the File? Checkbox -- is that what I'm supposed to do? Or how am I otherwise supposed to direct Omeka to import these files?

Here's my CSV for this:
52 Mules,LAPL,11/11/50,52_Mules_resized.jpg
Aqueduct pipe preparations,LA DWP,11/15/49,Aquduct_Pipe_Preparation3_resized.jpg
Zanjeros,LA DWP,11/10/48,Deputy_Zanjeros_2_resized.jpg
LA River and Lincoln Heights,LA DWP,10/19/09,lar and lincoln heights from elysian park 1909-1.jpg
Protest for State Park,LAPL,10/19/87,protest_for_state_park.jpg

Any help would be so greatly appreciated!

Most likely the problem is the path to your files.

I just tried a simple csv import on Omeka.net and successfully imported a file from a url.

Is any of the content you are trying to access from ContentDM only available with a login or through a specific IP address? If that is the case, Omeka.net can't actually access those files.

In the case of the jpgs you listed above, I didn't see a file URL, only the file name. In order to import them, those files will need a stable URL where you can import them.

Try this example:
Title, Creator, Description, File
Crosley portable radio, Nam June Paik, plastic and electronic components, http://americanart.si.edu/images/NJP/NJP.1.RAD.12_1a.jpg

Also, in Step 1 of the CSV Import process, be sure you are not checking the box next to "Use an export from Omeka CSV Report" -- that is only to be checked when you're importing items from an omeka.net export, not for any other types of imports.

Hi Sheila,

I really appreciate your getting back to me about these questions, and the import example you gave me worked perfectly :)

Based on your comments, am I correct in concluding that there's no way to use the CSV import function to import multiple files that reside on my hard drive or are "hidden" within ContentDM logins or specific IP addresses? Are there any workarounds, or would I need to add each item individually?

Thanks again!

You are correct.

You can still import all of the item metadata through a CSV file, and that will help.

As for files, you would then need to upload files to each item by hand.

The only other option to importing files and item data from ContentDM system would be if it has an option to harvest data using OAI-PMH. You could then use the OAI-PMH Harvester plugin to pull in item data and files.

Here is more info: http://info.omeka.net/build-a-website/manage-themes-and-plugins/oai-pmh-harvester/

You may need to ask the administrator in charge of your ContentDM installation about this.

Sheila, thank you so much; I really appreciate your clarifying these things! You and Patrick have been very helpful!

At Folkstreams, we have a large number of jpg images associated with our films. Fortunately, they were already online on our website. I just exported URLs for them and imported them as Files into Omeka using CSV Import. You could upload your images to an open web server and then point to them in your CSV file. I am not familiar with the features of ContentDM, so I don't know if its possible to export them to a web server. You would also have to create a CSV file with the correct URLs to the images. This was easy for us because our existing system stores image locations. I exported the CSV content directly from our database using a SQL query designed to retrieve and assemble the data we needed to transfer into a format CSV Import could digest.