CSV Import seems to be corrupting database

getting the following error:

Mysqli statement execute error :
Incorrect key file for table

This has happened a few times in the past 24 hours, always during a CVS Import action (either the import or the undo process). I previously re-installed Omeka completely to make sure it wasn't something I had done. I use the CSV Import plugin frequently, usually without any real problems, which makes me think there is something in one of my current CSV sheets that is breaking the database somehow.

I can't get at any pages where items are listed (both in the public and the admin views) though everything else works fine. I'm also unable to load the most recent additions to item-related database tables (in PHPmyAdmin).

The last CSV import we ran got hung up, so we hacked a URL to try to force an "Undo Import" link, but that is also hung up. The sheet in question is listed blow, though it's not the only one causing troubles.


Have you tried REPAIR TABLE omeka_element_texts?

Oh, right. Good idea. That helps. I can now access everything. Though deleting the most recent (incompletely imported) item prompts the following:

Item with ID= does not exist


Mysqli statement execute error : Can't find record in 'omeka_entities_relations'

Looking more closely, I see that there are 3 items with the same ID "1834" and title "[Untitled]"

Like it tried 3 times to create the same item?

Another repair, by the way, fixed that too, but I'm still left with this hanging undo/import issue. And also wondering why the sudden occurrence of so many errors in this normally stright-forward process?

CSV Import really doesn't do anything out of the ordinary, database-wise, except that what it does, it does in bulk.

I'd suspect some problem at a layer lower than Omeka. You could be seeing some corruption from a MySQL bug (old versions do have some). Something could be crashing your MySQL server, which would account for the broken tables (you can check your MySQL server logs to see if that shines any light on the subject).
Finally, it's possible that you're having a hardware problem such as disk failure which is corrupting MySQL's files.