CSV Import problem

I am using CSV Import to upload metadata for 176 items and mapping one field to image files in the Dropbox. I go through the process, get no errors but nothing uploads. The CSV files remain in the Status list with a zero item count and status of 'Import in progress.'

Any ideas what I'm doing wrong here? Is there a way to stop and/or delete jobs that aren't working from the Status list?

I'm on version 1.0 and I'm a brand spankin' new user so there could be something I just missed :) Thanks!

Are you using the latest version of the CSV Import plugin? Could you attempt to import the test.csv file that's included it the latest version?

Double check your PHP-CLI, and make sure that you're running PHP5 on the command line.

If you'd like to remove your "import in progress" messages to go away, you'll have to uninstall the plugin at this time. Typically, the plugin will display an error message for a failed import, however it appears that your background process died before Omeka was able to print that option.

Thanks for the response. I installed version 1.1 of the plugin and got the same hangup problem with the test.csv. My host indicates I am running PHP 5.2.6. but I don't have command line access.

The CSV Import plugin (as well as the OAI-PMH Harvester) requires command line access in order to run the import. This is necessary due to the size of the tasks, and would likely time-out if attempted over HTTP.

Okay I'm back. It turns out I can access via command line. How exactly would I run the import that way? The documentation says nothing about executing via command line. In fact it leads one to believe that everything can be done via web admin.

I am also very curious about this - I'm having the same problem. I'm very excited about the potential of the CSV import, so I really hope I can get this to work. I did ask my host about the CLI path, and they told me this:

The path to the PHP script is given below:

so that's what I put in when configuring the plugin, along with a -1 maximum memory limit.

I have another test site that is not hosted, but I have very limited access to the local server, so that's a different set of problems.

Any advice is very much appreciated!


I keep trying - my hosting provider suggested I try a different path:


but that doesn't seem to be working either.

could it be that the path is relative, and not quite right for the particular folder I have omeka in?

any advice about what that path usually is, in relation to one's Omeka folder?

I really want to get this up and running for a student project before the end of the semester - please help!


Hi Arden,

Incredibly sorry we haven't responded to you in so long. Try /usr/local/lib/php5. You shouldn't have to put -cli at the end of it, as far as I know.


Thanks so much, Jeremy!
Unfortunately, it still isn't working. Here's the latest response from my provider, ipower:

"We apologize for providing you with inaccurate information earlier, and we regret any inconvenience that may have caused you. The path to the PHP-CLI command is given below:
The cli path on PHP is works only for shecdule job, that won't work for Omeka plugin. "
Yes, that's an exact quote.

So, it sounds like this is a dead end for me with this host, unless you can think of any work around.

Can you recommend any other hosting providers that others have used, especially using the CSV import? Has anyone used the CSV import on DreamHost?

Thanks for your help!

Sorry to hear that you ran into a dead end with your current host. Yes, the CSV import plugin works with Dreamhost. There's also a page on the codex with other hosting suggestions: http://omeka.org/codex/Hosting_Suggestions

Good luck!


I'm unfortunately having the same problem. I'm hosting my own server and followed your directions exactly. It is Ubuntu 9.04 server. The only path I could find is usr/share/php5, which has php.ini-dist and php.ini-dist.cli inside of it. This seems like it is the correct place but my import is frozen, with only 6 records. No errors, but nothing is changing either after 10 minutes.

Any suggestions?



Hi again,

I ran the following command:

sudo apt-get install php5-cli

because some users said PHP CLI needed to be installed separately. Anyway, this was the final line of the install process:

Creating config file /etc/php5/cli/php.ini with new version

Does this not mean that the correct path is "etc/php5/cli"? I assume the backslash at the beginning should be removed.

Now I have three imports "in progress" but nothing happening. I suppose changing the settings midstream does not help. It would be nice to be able to delete ongoing imports, regardless.

Any assistance is sincerely appreciated. Thanks, Jamil

Hello again,

I solved my problem. The correct path in ubuntu (and I do believe you need to install the php5-cli package first) is /usr/bin/php. However, after entering the incorrect value, I was simply unable to change it using the configure panel. I had to trash the mysql table I was using by changing the prefix.

Anyway, it finally works—and quite well I might add.



Hi Jamil,

Glad you got it working!