CSV Import Plugin Not Working on Shared Host

I'm trying to use the CSV Import plugin. I got it to work locally on my MAMP installation, but I can't make it work on my Bluehost site. I keep getting the following runtime exception:

The configured PHP path (/usr/bin/php) does not point to a PHP-CLI binary.

Based on what I read in other threads, I started playing with the value of background.php.path in the config.ini file. I checked my PHP_BINDIR variable, which is /usr/php/53/usr/bin. I tried that value and all sorts of other things, but the keep getting the same message (well, with different values in the parens.)

I'm having the same problem on another hosted server (Lunarpages).

I'd be interested to know if anyone on a hosted server has gotten CSV import to work and, if so, how.

BTW, I'm running Omeka 2.0.2 and trying to run CSV Import 2.0. My PHP version (on Bluehost) is 5.3.22.

When you change the path, is it changing the path that Omeka complains about in that error, or is it always exactly the same?

Sorry, that's what I meant by "different values in the parens." The error message reflects the value to which I have set background.php.path in the config.ini file.

Wow. It finally worked. I wrote to Bluehost and they said that the correct path to use would be:


I used that value for background.php.path and everything went smoothly.

WOW, thank you! I ran into the same problem and we also use bluehost as hosting server. Just tried your solution, it worked perfectly.

Thank you! I had this similar problem and needed to locate the path for php-cli.

Really strange that this happened as I've set up other omeka implementations on the same hosting platform (Reclaim Hosting) and CSV Import has worked fine!