CSV Import failing to import file

CSV Import isn't importing files. If the 'Files?' box is checked then the CSV Import status stays at 'In Progress' though the item will still be created, without the file being associated with it. If there is more than one item in the .csv file then items after the first file address entry won't be imported at all - it seems to be hanging at that point. It works fine with a .csv file that contains no file column, or even one that does provided I never select the Files? box.

I've tried it with files in Dropbox (using the full address), and with wikipedia files, including the one in test.csv in CSV Import - http://upload.wikimedia.org/wikipedia/commons/b/ba/Henry_David_Thoreau.jpg.

Maximum file size is 100 MB, the files I've tried to import are much smaller. I'm using the latest versions of Omeka and CSV Import.

Is there something very simple I'm not doing?
My procedure for using CSV Import is:
1. Select .csv file
2. Select item type
3. Make all items public
4. Click Next
5. Select Files? checkbox. (Map to Element is left at 'Select Below' for Filename)
6. Click Import CSV File

Sample CSV file data:

Dublin Core:Title,Item Type Metadata:Year,Item Type Metadata:Volume Number,Filename
IESIS Transactions Volume 146,2003,146,http://upload.wikimedia.org/wikipedia/commons/2/25/Walden_Thoreau.jpg

Your CSV looks fine, so I'm guessing something else (like ImageMagik) is the culprit.

If you follow these directions to turn on error logging, you should be able to retrieve a specific error message:
This will make it easier to troubleshoot your problem.

I do already have SetEnv APPLICATION_ENV development uncommented, but I haven't seen any error messages. I will investigate whether I'm using the right path for ImageMagick.

EDIT: Apparently /usr/bin is correct for ImageMagick.

Have you also turned on error logging in the config file? Most CSVImport errors only go to the log, they don't display on screen.

All the methods for retrieving error messages, including error logging, have now been activated. There are no error messages when CSV Import attempts to add a file to an item. However the following message is logged when I add a file to an item manually via the admin interface.

2015-02-05T20:41:23+00:00 WARN (4): Error output from ImageMagick:
**** ERROR: Unable to process JPXDecode data. Page will be missing data.

Adding the file manually works, apart from these error messages. It doesn't seem to matter whether Omeka is getting the file from my desktop PC or Dropbox.

There is a longstanding possible problem with Ghostscript on the webhost I'm using. As I understand it they haven't upgraded to the latest version. This may be what causes thumbnail images on the site to appear blank (this in itself isn't a problem as they are not necessary for the application). This might be related to the logged error.

When CSV Import hangs on 'In Progress', [my domain]/admin/csv-import/index/undo-import/id/[ID] can be used to stop it hanging, but that doesn't remove the item that was added.