CSV Import - import stays queued

I’m having the same problem that was originally mentioned in this thread:

When trying to import a csv file using CSV Import v.2 on Omeka 2.0.1, the import status stays queued but never imports.

I’ve tried deactivating and uninstalling all other plugins, then reinstalling CSV but even when CSV is the only plugin installed, the status never gets beyond queued.

There are no errors showing anywhere – and error reporting is turned on in Omeka. This happens with the test.csv file as well as with our own csv files. I’ve tried in both Chrome and Firefox – same issue.

We are running Omeka on Windows server 2008 R2 enterprise. Any help or ideas would be greatly appreciated!

Have you set the PHP-CLI path in your config.ini?

The process-spawning and path-guessing parts of Omeka are some of the more Linux-specific portions. To even have a chance of having it work in Windows you'd need to set background.php.path

Hi John,
We have set the PHP-CLI path and are not getting the path error. The import hanging at queued seems to be a different issue.

You can try avoiding the background process altogether. This means all the CSV processing will happen in one web request, so for bigger files the PHP settings on execution time would become more important.

To use "synchronous" processing instead, change this setting in config.ini (or create it if it doesn't exist):

jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_Synchronous"

Thanks John. We'll give it a try next week.

It looks like that did the trick for us. Thank you so much, John!

related question: I am getting this error when I try to use the 2.0 compatible csv import plugin:

The configured PHP path (/usr/bin/php) does not point to a PHP-CLI binary.

I am not sure what to do in my config.ini to fix this. Could someone please help with some lines of code? Thanks

Look for this line:

background.php.path = ""

and put in the correct path. You might have to ask your server admin or hosting company what the correct path should be