CSV Import - files not loading

Omeka version 2.0.2, CSV Import plugin 2.0.3. I import a CSV file that has one column "Item Type Metadata:URL" that holds the URLs of the files I want to upload. The other metadata columns seem to load fine, but the files never seem to get fetched from the URLs. What am I doing wrong? I've verified the files are freely fetchable at the address provided.

OK, maybe I need to ask this a different way. I have no clue what the mechanism is that is used to take the URL in my CSV file and fetch it from where it is on the web. Do you use curl? wget? Where in the code can I find the mechanism and them maybe I can debug this thing.

Two pieces of information would help--the first few lines of the CSV you're using, and whether or not CSVImport provides a specific error message. You can follow these directions to turn on error logging.

The top 3 lines:

Item Type Metadata:URL,Dublin Core:Date,Dublin Core:Title,Dublin Core:Creator,Dublin Core:Format,Dublin Core:Rights,Dublin Core:Type,Dublin Core:Source
http://roytennant.com/stanfiles/Scan-141204-0001.jpg,June-79,A raft floating the river.,Coni Beeson,JPEG,Copyright Coni Beeson. All Rights Reserved.,Image,Color Slide
http://roytennant.com/stanfiles/Scan-141204-0002.jpg,June-79,River level view of a small rapid.,Coni Beeson,JPEG,Copyright Coni Beeson. All Rights Reserved.,Image,Color Slidehttp://roytennant.com/stanfiles/Scan-141204-0003.jpg,April-78,The Melones area.,Coni Beeson,JPEG,Copyright Coni Beeson. All Rights Reserved.,Image,Color Slide

But in the upload process, I don't see a good choice for specifying where the URL to fetch should map to. I have a screen shot of the screen I am seeing, but nowhere to send it.

I see:

Item Type Metadata:
Original Format
Physical Dimensions
Dublin Core:


In your csv, there is no comma after "Color", just before the url. Try the samples provided in csv_files to know if the issue is related to your files or to the config. The sample loads images from wikipedia, so they are always available.


Daniel Berthereau
Infodoc & Knowledge management

The file URL actually doesn't map to to a column in the same way as everything else, which can be a little confusing. Instead, there are three columns of checkmarks at the end of each line in CSVImport, with the last being "Files?" To get Omeka to recognize your file URLs as files, you have to check that box for the appropriate column of your CSV.

OK, I did the test file test_automap_columns_to_elements.csv and it still doesn't import the file specified at the URL. I still haven't had my question answered about how the files are fetched. Maybe there is a problem with that mechanism? Perhaps I don't have something installed I should have?

Files are loaded by checking the "Files?" box for the appropriate column in your CSV. You can see what that looks like in the third image of the plugin direction page.If that box is checked, and the files are still not imported, there really should be an error message in the log if you followed the directions I posted for turning error logging on (typically I get MIMEtype errors for 404 pages). If you haven't already, please follow these directions to turn on error logging.

This is the code for the item import. It uses the insert_files_for_item function.

Well, duh. I finally heard what you were telling me. I completely missed the "Files?" checkbox. From a UI perspective, it's best to avoid exceptions. If there had been an option on the dropdown to map that URL column to "URL", I would have happily done that and been on my way. Just a suggestion. Thanks for hanging in there until I got it.