CSV Import File Mime Type Cannot be Determined

The players:
Omeka 1.4.1
CSV Import 1.3.1
Mac OS 10.6.8

Security Settings: Disable Upload File Validation - checked, but probably unrelated.

To make a long story short, I am trying to use CSV import but each time I try, I get this error message:

"The file 'whatever.csv' could not be ingested because its media (MIME) type could not be detected."

I have tried using Microsoft Excel, Open Office, and even Dreamweaver to generate the CSV. I have tried putting quotes around spaces and commas, and then finally eliminating the data that is more than one word long just to test. I have made sure my encoding is UTF-8 when I get the chance, but it is most likely that I tried non-UTF-8 as well.

I even used a Windows 7 machine to create the CSV. I am out of ideas. Anyone have any experience with this?

This sounds like part of a broader issue we are addressing on our end. The file validators we use depend on information reported back from the servers, and there are many variables on that side that we are working to account for better.

There might be better solutions, but if I were getting desperate I would try the following. Go to the plugins directory; and find and open the file CsvImport/forms/Main.php.

Then, comment out this line:

private $_requiredMimeTypes = array('text/csv', 'text/plain');

so instead it looks like

// private $_requiredMimeTypes = array('text/csv', 'text/plain');

I haven't tested this yet, but it might skip over the MIME type checking and let things continue.

Hope that helps!

Patrick, you are my hero. That worked!

I sincerely appreciate your help!

Glad it helped! Keep in mind that when you update the CSV plugin, it could overwrite that change, in which case the same problem could occur.

Thanks for the post, Patrick, this worked for me as well.