CSV import

I've been trying to import a spreadsheet from Excel into Omeka as a CSV file. Each time it tells me the CSV file is incorrectly formatted. I removed all commas from the spreadsheet and have tried the Macintosh and MS-DOS CSV options.

Has anyone else had this problem? How did you solve it?

When creating the CSV file, and Excel asks if you want to change the format of your data in the current file do you say Yes? If you do not, the spreadsheet won't be saved in proper CSV formatting.

When you say that you deleted all of the commas, did you deleted the commas that separated each column of data?

We do say Yes to changing the format. I deleted the commas that were already in our data. I have not changed anything related to CSV formatting.

We have tried simplified files with fewer fields but they do not work either. We have also created CSV files from Access. Is there another program we could use to create CSVs?

I'm sorry that I can't give you more help here. I have had success converting files from both Access and Excel into CSV files that have imported using the plugin.

Here is a short tutorial for creating and checking CSV files generated from Excel 2007. I'm sure you have done this, but you might want to hunt around and see if there are other bits of advice online that might help from MS end of things: http://www.brighthub.com/computing/windows-platform/articles/30292.aspx

Thank you for your suggestions. It turns out it was a problem with our server. Our ITS department has already corrected the problem and we were finally able to import our data!

I ran into similar problems until I made sure that every single field was treated as text, and had quotes around them. You can do this in Excel under Format-Cells, and change any numbered field from number to text.