CSV 2.0 import stays queued

Hi, I have been trying to import a csv file file using csv 2.0 in omeka 2.0.1, but the import stays as status queued. I have used my own, as well as the test.csv file that comes with the plug-in, but after I map the fields, the import remains queued. Any assistance would be great as to where the hang-up is.


sorry, that last line should have read:

Any assistance would be greatly appreciated.

Thanks again.

I should also add, that so as to isolate where the issue may be, I have tried importing a url to an image both as a file and an identifier. Neither attempt effected the end status.


Have you tried temporarily deactivating your other plugins to see if there's a conflict occurring?

Hi John,

Thanks. I had de-activated them with no change, but after your post, I decided to uninstall them altogether, and now it is working. Thanks for your help.


Just to double-check, is CSV import now working with the other plugins reinstalled?

I will re-install the other plug-ins later to test to see which one was tripping csv up (if it still trips it up) and report back to you.

So it looks like the CSV Import plug-in doesn't play well with the Social Bookmarking plug-in.

Interesting....thanks for the info!

Jason which version of Social Bookmarking are you using?

It was version 2.0 that I had installed at the time.

I have all other plugins turned off.

gnosis_omeka, are you saying you have all other plugins off and you still having the same import issue?

Jason, I am trying to reproduce the Social Bookmarking conflict. I installed Omeka Version 2.0.1. Then I installed Social Bookmarking 2.0. Then I installed CsvImport 2.0. Then I imported test.csv. The import settings were default on the first page, except I made the items public and featured. Then I mapped the columns to their corresponding DC fields. I made the last two columns, tags and files respectively. The import was successful for me. I am not yet able to reproduce the issue.

Jason, what error did you get when you say "doesn't play well"? Thank you.

The import stayed queued. I didn't check the specific error at the time. I will say that I installed CSV first and then Social. As for the mapping of the test.csv, I also went with the corresponding dc fields, tags, and I tried it with the files as files and identifier. My imports were marked public, but not featured.

Hmmm... I just retried what you describe, but still can't reproduce the error.

When you had the error, were you using an existing Omeka site that had previously used CsvImport and Social Bookmarking plugins? Did you click the upgrade buttons for these plugins before you encountered the error?

It was a fresh virgin 2.0.1 install. Once I uninstalled the social bookmarking plug-in, the import was successful.

and to add, when I re-installed the Social Bookmarking plug-in, the csv import stopped working. I downloaded and installed the all the plug-ins Friday night.

Yes, wanderwill.

Any body else discover?

To jump in add something further to this, I recently found myself unable to use CSV Import Version 2.0.2 as the items would remain queued.

After a bit of trouble shooting, the culprit plugin appears to have been Commenting
Version 2.1. When this was uninstalled I was able to use the CSV Import as usual.

Wish that was the issue because I was not using Commenting Version 2.1, still experiencing this issue.

We just upgraded to Omeka v.2.2.2, and are experiencing a similar plugin conflict with CSV Import, version 2.0.2. The conflicting plugin is one I wrote specifically for our client, but didn't release it publicly (it utilizes "Guest User", and lets users create sets of items, which they can later download associated image files as zips). When that plugin is active, CSV Import has a similar problem as described by others: the items remain queued. When the plugin is deactivated, then CSV Import works fine.

I sort of need to get both plugins working together for our client....does anyone have suggestions on what things to look for that might cause the CSV Import to be stuck at "Queued"?

Thanks for any forthcoming ideas,

For whatever it's worth, updating the config.ini file (as John Flatness had suggested in a similar thread) as follows allowed the plugins to coexist:

jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_Synchronous"

If you turn on error logging, there might be something there to guide us to the details of the conflict.

But if that change to the dispatcher works, and you don't have CSV files that are big enough that they timeout, that might be the most expedient solution. That said, I know that it's often happier to actually find and fix the issue, rather than work around it.

Thanks Patrick. I'll go that route b/c it turns out that making that change in config.ini has broken derivative image creation...at least at the default setting.

Kinda stabbing in the dark, but maybe there's something in an after save hook? If the code of your plugin is available somewhere, it might also help us track down what's happening.

I think there is an undiscovered limitation that has not been discovered. After many attempts of not wanting to load and complete, a load worked. I tried again, with the same exact data-set and it did not work again.