CSV 2.0 errrors

Import does not work and getting the following errors during a CSV import:

Omeka_Controller_Action_Helper_Db: No ID passed to this request

#0 /var/www/html/omeka2/application/libraries/Omeka/Controller/AbstractActionController.php(121): Omeka_Controller_Action_Helper_Db->findById()
#1 /var/www/html/omeka2/application/libraries/Zend/Controller/Action.php(516): Omeka_Controller_AbstractActionController->showAction()
#2 /var/www/html/omeka2/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('showAction')
#3 /var/www/html/omeka2/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#4 /var/www/html/omeka2/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#5 /var/www/html/omeka2/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#6 /var/www/html/omeka2/application/libraries/Omeka/Application.php(79): Zend_Application->run()
#7 /var/www/html/omeka2/index.php(23): Omeka_Application->run()
#8 {main}

Also posted here:

What page are you going to that gives you this error?

This doesn't look like something the CsvImport plugin would do, it just looks like a fairly standard 404 "not found" error, but with "debug.exceptions" turned on.

The public display. The import does not import. Used several of the same csv files that i successfully used with previous versions of OMEKA and CSV importer.

The CSV importer does not even import one of my records. Just says <In Progress> so I check the public side.

Do you have a CSV file that work, that I can test against my install?

The plugin itself comes with two sample CSV files in the csv_files directory.

Got a little further. Imported test.csv.

In the admin status says
0 items imported
Status is "In progress"

However on the public side, item meta-data appears, but NOT images.

Started with a clean install. Noticed this message during install:

"fileinfo" module not loaded

Could this be my issue?

I ran:
"sudo pecl install fileinfo"
and restarted apache, but still getting the same error.

Any body else discover?