Contributions Plugin - making items public

I am having trouble making items public after they are contributed by a guest user. [As I am still testing, the guest user is me, set up with another email address.]
I contribute the item, making sure I click "Publish my contribution on the web". When I then log in as the administrator, although I can supposedly edit the item and make it public, the next time I view the item it is still not set as public. When I actually click Save Changes after making the item public, I get a white browser screen which simply has the message: myname@gmail.comYour contributed item is now publicly visibleThank you for contributing! Your contributed item has been approved and can now be viewed at the following link: ViewMIME-Version: 1.0 Content-type: text/html; charset=iso-8859-1
There is nowhere to go from this screen really. Clicking the View link takes me back to the item admin screen, where it is not public. Clicking the back button takes me back to the item admin where public is ticked but I need to save changes.

Every time I save changes I also get an email to the guest user account saying:
Apache <apache@localhost.localdomain>
to me
Thank you for contributing! Your contributed item has been approved and can now be viewed at the following link: View
When I click that View link, I get a 404 because the link address is actually incomplete, missing the top level domain.

Can anyone tell me what might be going wrong?

There's definitely a lot that's not working as it should, but I'm not sure where exactly the trouble is yet. For one, it seems like somehow the email message is showing up in that white browser screen, which is definitely a mystery.

A couple questions --

1) What version of Omeka and Contribution are you using?

2) Can items created the usual way, not through Contribution, be made public?

Thanks Patrick.
Omeka version is 2.3
Contribution version 3.0.3
Guest User version 1.1.1

Yes - items added either via csv import or added directly through admin can be made public.

The other issue I am having is that although I received the user emails (confirm registration, an admin has approved etc) for the gmail address registration, a second test guest registration using a email has not received an email at all. I tried resending it from the admin interface but no luck.

For the missing emails, first I'd say to double-check spam/junk email folders to see if they went there.

I'm still a bit baffled, but my next question is whether you are using the Contribution plugin from, or one of the various forks of it?

Yep - been checking spam folder - nothing at all.

The plugin is from
Is it worth uninstalling it completely and starting from scratch?
I have another Omeka instance where it is installed too but not yet activated - I was using this test one to figure it all out for that one. Shall I see if it works properly in that one?

I just tried it in the other Omeka instance. I still don't receive any email to the Bigpond address, but despite that, when I activated the account (as admin) and contributed an item (as guest), I was then able to make that item public successfully via the admin interface.

My first thought is to completely uninstall and start from scratch, but that's kind of a hail mary.

It'll also be worth turning on both error messages and logging as described here. Then seeing what new info is displayed or shows up in the log file.

Does any of the text in the whitescreen you get (e.g. "has been approved" or "can be viewed") look like it came from any of your configuration of the plugin? I'm trying to track down what might be producing that message (which does still look like an email going awry)

I didn't set up any email text in the configuration so I'm not sure where that text came from.
I just tried as the gmail user in the new (other) instance and again was able to make the item public. However I did not receive an email like the one in the browser on the other instance.
I can ask my tech person to enable error messages display but I am not sure whether I can get that done today so we may need to pick this up in the new year. Thanks and Merry Christmas!

Makes sense to me! Hope Santa treats you well!

Happy New Year :)
To continue our discussion around the issue I experienced with the contribution plugin..
Today I tried (in my test Omeka) deactivating and reactivating the contribution plugin. This actually seems to have solved the 'making contributed items public / weird white screen' problem.!
The only issue now is that the bigpond email address still does not receive any notifications - I will have another look at settings to see what might be happening there.
Thanks for all your input.

Actually, the deactivate/reactivate did nothing, I can now see that the 'making items public' problem occurs when I also use the Contributor Contact plugin -
Version 1.0.2 by UC Santa Cruz University Library.
So I think for now I will do without :)

Ah, some odd conflict, then. It might be worth reporting this as an issue on their GitHub repo.